Results 1 to 8 of 8

Thread: Mitsubishi MHK2 stuck on wait

  1. #1
    Join Date
    May 2021
    Posts
    3
    Post Likes

    Mitsubishi MHK2 stuck on wait

    I'm connecting the MHK2 to an SVZkp 30.. I plug it into the correct spot on the AHU and it connects but it stays on waiting and won't do anything else to. I have a branch and a 3 ton hyper heat but that shouldn't matter. Not sure why I can't get there thermostat to connect. Never had this happen before

  2. #2
    Join Date
    Feb 2018
    Location
    Bay Area, Ca
    Posts
    1,378
    Post Likes
    Quote Originally Posted by Antman35 View Post
    I'm connecting the MHK2 to an SVZkp 30.. I plug it into the correct spot on the AHU and it connects but it stays on waiting and won't do anything else to. I have a branch and a 3 ton hyper heat but that shouldn't matter. Not sure why I can't get there thermostat to connect. Never had this happen before
    Is it possible it was previously used or installed. I had 2 out of the box that did that. I had to bypass it and do a factory reset and enter all the number sequences again. But after that it worked fine. They were new but the box was open... hope that helps. Goodluck.

    Sent from my SM-N960U using Tapatalk

  3. #3
    Join Date
    May 2021
    Posts
    3
    Post Likes
    Thread Starter
    It was new in the box. But who knows could have been returned to the supply house. How did you do the reset?

  4. #4
    Join Date
    Feb 2018
    Location
    Bay Area, Ca
    Posts
    1,378
    Post Likes
    Quote Originally Posted by Antman35 View Post
    It was new in the box. But who knows could have been returned to the supply house. How did you do the reset?
    Exact method I dont recall but its in the advanced settings. And the install book.

    Sent from my SM-N960U using Tapatalk

  5. #5
    Join Date
    May 2021
    Posts
    3
    Post Likes
    Thread Starter
    Thanks for the help but I can't get to the advanced menu options. The screen is just stuck on wait. Doesn't give any other options

  6. #6
    Join Date
    Oct 2011
    Location
    Culver, Oregon (Central OR)
    Posts
    4,097
    Post Likes
    Are you a pro?

  7. #7
    Join Date
    Feb 2013
    Location
    Sonora, California, United States
    Posts
    5,933
    Post Likes
    Had same issue recently. bad out of box....

  8. #8
    Join Date
    Aug 2016
    Location
    Houston TX
    Posts
    130
    Post Likes
    Quote Originally Posted by Antman35 View Post
    I'm connecting the MHK2 to an SVZkp 30.. I plug it into the correct spot on the AHU and it connects but it stays on waiting and won't do anything else to. I have a branch and a 3 ton hyper heat but that shouldn't matter. Not sure why I can't get there thermostat to connect. Never had this happen before
    Did you check your communication wiring through out the system to make sure it is connected properly? What is the model of the outdoor?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •