Results 1 to 14 of 14

Thread: Help!!! Water cooled chiller

  1. #1
    Join Date
    Jun 2019
    Location
    Viet Nam
    Posts
    13
    Post Likes

    Help!!! Water cooled chiller

    I have problems, my chiller shutdown 2 times but everything of the chiller system seen looks fine.
    Someone can tell me what happened with my chiller?
    https://imgur.com/a/xySEnKe

  2. #2
    Join Date
    Jan 2015
    Location
    Somewhere making cold water
    Posts
    324
    Post Likes
    Need more information, running logs would be a good start.


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Feb 2017
    Location
    New York
    Posts
    1,666
    Post Likes
    Quote Originally Posted by WYLBEK View Post
    Need more information, running logs would be a good start.


    Sent from my iPhone using Tapatalk
    X2

    Sent from my SM-G935U using Tapatalk
    -----Stop, step back, relax and have another go at it.-----

  4. #4
    Join Date
    Sep 2002
    Posts
    30,295
    Post Likes
    Yes; we can.

    Please post the following:

    System Refrigerant
    Cooling application
    Chilled fluid type?
    Design leaving chilled fluid temperature (in degrees F.)
    Outdoor ambient temperature and RH%
    Head Pressure in pounds
    Suction Pressure in pounds
    Chilled water flow in GPM
    Condenser water flow in GPM
    Chilled water temps in and out
    Cond. water temps in and out
    Discharge line temperature
    Suction line temperature
    Liquid line temperature
    Compressor FLA
    Compressor amps at failure
    Load percentage
    DX chiller?
    Flooded chiller?
    Type of head pressure control?
    Time of day of failures?

    PHM
    ----------


    Quote Originally Posted by James nguyen View Post
    I have problems, my chiller shutdown 2 times but everything of the chiller system seen looks fine.
    Someone can tell me what happened with my chiller?
    https://imgur.com/a/xySEnKe
    PHM
    --------
    The conventional view serves to protect us from the painful job of Thinking

  5. #5
    Join Date
    Jun 2019
    Location
    Viet Nam
    Posts
    13
    Post Likes
    Thread Starter
    Thank you all guys,
    I will check later all the information.
    This is the event log on the chiller control panel
    [IMG][/IMG]
    [IMG][/IMG]
    [IMG][/IMG]

  6. #6
    Join Date
    Dec 2019
    Posts
    1
    Post Likes
    check water pressure seen it low or pressure switch.

  7. Likes James nguyen liked this post.
  8. #7
    Join Date
    Jan 2013
    Location
    United Kingdom
    Posts
    336
    Post Likes
    Well it looks like a remote interlock is stopping the chiller then re-starting it, what remote interlocks have you got wired in ?

  9. Likes James nguyen liked this post.
  10. #8
    Join Date
    Aug 2019
    Location
    LA
    Posts
    166
    Post Likes
    The pic with the load dropping out and then picking back up looks like a board issue. Maybe a isolation board or bad CT. Restarting with out alarm or delay timer is control.

  11. Likes James nguyen liked this post.
  12. #9
    Join Date
    Jun 2019
    Location
    Viet Nam
    Posts
    13
    Post Likes
    Thread Starter
    Of course, this chiller is running auto under the BMS system at the moment.
    I ask my man to check everything including wire connections. But I don't know what reason.
    Can you tell me what happens if the flow switch flashing?

  13. #10
    Join Date
    Jun 2019
    Location
    Viet Nam
    Posts
    13
    Post Likes
    Thread Starter
    If the flow switch opens the chiller will off and on the control panel will have an event about this.
    But I don't see anything event.

  14. #11
    Join Date
    Jun 2019
    Location
    Viet Nam
    Posts
    13
    Post Likes
    Thread Starter
    Quote Originally Posted by dennis d nguyen View Post
    check water pressure seen it low or pressure switch.
    If the flow switch opens the chiller will off and on the control panel will have an event about this.
    But I don't see anything event.

  15. #12
    Join Date
    Jun 2019
    Location
    Viet Nam
    Posts
    13
    Post Likes
    Thread Starter
    Quote Originally Posted by raptyr View Post
    Well it looks like a remote interlock is stopping the chiller then re-starting it, what remote interlocks have you got wired in ?
    Of course, this chiller is running auto under the BMS system at the moment.
    I ask my man to check everything including wire connections. But I don't know what reason.
    Can you tell me what happens if the flow switch flashing?

  16. #13
    Join Date
    Jan 2013
    Location
    United Kingdom
    Posts
    336
    Post Likes
    How frequently is the problem happening? Do it occur at the same time every day ? Is there a trend to it? Can you run the chiller in Local Mode with the BMS dis-connected ? Then see if it trips, you should still keep any external safety devices connected , flow switch, remote overloads etc

  17. #14
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    33,595
    Post Likes
    From the screen shot Remote OFF.

    Place the unit in LOCAL operation and see what happens!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •