Results 1 to 10 of 10

Thread: FP new SC480 Clamp Meter

  1. #1
    Join Date
    May 2018
    Posts
    237
    Post Likes

    FP new SC480 Clamp Meter

    I just noticed something unusual about the operation of the newest FP clamp meters. Not surprising, but still unusual.
    The NCV detection goes absolutely crazy in the presence of flourescent lighting, beeping continuously when more than 10 feet away and more. My FP SC440 is a very good, trustworthy NCV meter that does not exhibit this behavior. In fact NONE of my other meters or tickers I have used or owned ever exhibited this behaviour either.
    Turn the flourescent lights out and the 480 works as expected. Is this a fluke (no pun intended) or is it normal? I can understand the interference, but shouldn't it have been filtered out?

  2. #2
    Join Date
    Mar 2009
    Location
    Pittsburgh
    Posts
    233
    Post Likes
    Interesting!!
    I’ll forward this to Fieldpiece engineering.


    Sent from my iPhone using Tapatalk
    Bill Spohn
    President & CEO
    www.TruTechTools.com

  3. #3
    Join Date
    Sep 2008
    Location
    VA
    Posts
    3,929
    Post Likes
    I'm gonna try this with my SC680. What type of fluorescent light? Large tubes or cfl's?
    "The only true wisdom is in knowing you know nothing" Socrates

  4. #4
    Join Date
    Sep 2008
    Location
    VA
    Posts
    3,929
    Post Likes
    Yep, the SC680 does, but I also tested my Fluke 117, and it does this as well. Weird..
    "The only true wisdom is in knowing you know nothing" Socrates

  5. #5
    Join Date
    Sep 2008
    Location
    VA
    Posts
    3,929
    Post Likes
    WOW!!!!

    It's the friggin Blue light waves. I put my clear blue light blocking monitor glasses between the cfl and the meter and it turned off. I'm definitely getting rid of the cfl's now.

    I could be wrong, but it's very interesting.
    "The only true wisdom is in knowing you know nothing" Socrates

  6. #6
    Join Date
    Mar 2007
    Location
    At The Point Of No Return
    Posts
    16,763
    Post Likes

  7. #7
    Join Date
    Sep 2008
    Location
    VA
    Posts
    3,929
    Post Likes
    Quote Originally Posted by itsiceman View Post
    LMAO, The pair I have are clear, not sure if they block UV, just blue light I think.
    "The only true wisdom is in knowing you know nothing" Socrates

  8. #8
    Join Date
    May 2018
    Posts
    237
    Post Likes
    Thread Starter
    Mine did it on 8' tube garage lighting.

  9. #9
    Join Date
    Mar 2007
    Location
    At The Point Of No Return
    Posts
    16,763
    Post Likes
    I don't get it on my DL429 which seems overly sensitive but they send my ultrasonic leak detector crazy.

  10. #10
    Join Date
    Jul 2019
    Location
    Oklahoma home its in the name
    Posts
    3,054
    Post Likes
    Quote Originally Posted by itsiceman View Post
    I don't get it on my DL429 which seems overly sensitive but they send my ultrasonic leak detector crazy.
    They drive my sonic leak detector (ears) crazy.

    Sent from the Okie state usin Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •