Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2010
    Location
    Coral Springs, Florida
    Posts
    509
    Post Likes

    Android 10 Problem with BluVac+

    Here's a heads-up for BluVac+ (Pro, LTE, and Micro) users with Samsung Mobile Devices:

    If you are having difficulty connecting your BluVac+ product to the BluVac app on Samsung S9, S10, Note 9, or Note 10, this is due to a bug in Android 10 that is preventing the gauges from connecting properly. Other Bluetooth enabled products from various manufacturers are also experiencing similar problems.

    Android and Samsung have been notified of the problem, and we hope they provide an update to fix this.

    Regardless, the performance of our products is important to us, so we developed a firmware upgrade that works around the issue and provides normal connectivity.

    Anyone who is experiencing this problem with their Samsung/Android 10 mobile device is urged to contact us at https://accutools.com/contact-us. We will reply with instructions as to how to get your firmware upgraded free-of-charge regardless of warranty status.

    Please note that this upgrade is not required if you use any iOS device, or if your gauge is operating correctly on an Android device.

    This upgrade will no longer be necessary once Android 10 is patched to fix the bug. I'll follow up here when that is the case.

  2. Likes rjk_cmh liked this post.
  3. #2
    Join Date
    May 2018
    Posts
    122
    Post Likes
    Just tried a quick check with a brand new One Plus 6t with Android 10.3.2 and it worked fine. I just got the Android update a few minutes before reading about the issue, so I don't know if the update is patched or if the problem never existed with the OP phones.

  4. #3
    Join Date
    Aug 2010
    Location
    Coral Springs, Florida
    Posts
    509
    Post Likes
    Thread Starter
    Quote Originally Posted by channellxbob View Post
    Just tried a quick check with a brand new One Plus 6t with Android 10.3.2 and it worked fine. I just got the Android update a few minutes before reading about the issue, so I don't know if the update is patched or if the problem never existed with the OP phones.
    Thanks for checking in, Bob.

    The best we can tell, only Samsung devices are affected. Why? Who knows. Maybe Samsung has a custom Bluetooth stack.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Contracting Business
HPAC Engineering
EC&M
CONTRACTOR