Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2018
    Posts
    3
    Post Likes

    Fan motor failure twice in 3 1/2 years

    I had a new matching Goodman system put in 3 1/2 years ago. The fan motor failed and needed to be replaced after 7 months. Now 2 years 10 months later the same problem.
    The first replacement was fully covered as it was under 1 year. But now the Labor charge is on me. What would you do if you were me? It just doesn't seem right!

  2. #2
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    25,542
    Post Likes
    Assuming this is an ECM Motor have the static pressure checked!

  3. #3
    Join Date
    Dec 2018
    Posts
    3
    Post Likes
    Thread Starter
    It is an ECM motor. Service man will be here soon.

  4. #4
    Join Date
    Dec 2005
    Location
    Cincinnati, Oh
    Posts
    7,209
    Post Likes
    Did you purchase a labor warranty?

  5. #5
    Join Date
    Jan 2014
    Location
    New England
    Posts
    6,261
    Post Likes
    Did you register it, as if not registered, your parts warranty drops significantly 10 years to 5 years. If you reside in California or Quebec, need not to register system to receive manufacturers maximum warranty.

    Guessing they never did a commissioning report on your system when they started it, as static pressure check is typically done.

  6. #6
    Join Date
    Sep 2007
    Location
    edmonds wa
    Posts
    4,423
    Post Likes
    Did you let the filter get plugged up?
    UA Local 32 retired as of Jan 2020

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •