Results 1 to 11 of 11
  1. #1
    Join Date
    Nov 2019
    Posts
    4
    Post Likes

    replacing thermostats

    I replace a mercury thermo. with a new one on a 22 year old split unit heat pump. Every thing comes on the way its suppose to runs for a min. then cuts off I have the thermo. compressor protection set on 2 min. but the defrost board makes it wait 5 min. then it comes back on for a few min. and repeats this over and over.I checked the df board its an old gibson I cant make it go into df but every thing else works. Iam hoping its the board,welcome all help full feed back thanks.

  2. #2
    Join Date
    Sep 2016
    Posts
    14
    Post Likes
    Is the thermostat programmed to be ran with a heat pump system?

  3. #3
    Join Date
    Nov 2004
    Location
    North Florida/South Georgia
    Posts
    1,004
    Post Likes

    RFI - and lots of it

    We need a lot more information to help here.

    Model # of unit

    Model # of thermostat

    While the model number will tell us many things, you could provide some helpful details as well.......

    1 stage?

    2 stage?

    Mfr?

    Etc etc

    Also, what was the model of the mercury stat.
    All my leon freaked out!

  4. #4
    Join Date
    May 2014
    Location
    Bay Area California
    Posts
    25,719
    Post Likes
    Indoor blower probably isn't coming on.
    I do a triple evac with nitro to remove non condensables.

  5. #5
    Join Date
    Nov 2019
    Posts
    4
    Post Likes
    Thread Starter
    yes

  6. #6
    Join Date
    Nov 2019
    Posts
    4
    Post Likes
    Thread Starter
    yes it is the old thermos. was a white & rogers don't know the model of unit it is a 1 stage cooling heat pump with heat strip the unit is a spilt unit 22 year old gibson

  7. #7
    Join Date
    Nov 2019
    Posts
    4
    Post Likes
    Thread Starter
    yes the indoor blower is coming on

  8. #8
    Join Date
    Nov 2006
    Location
    Athens, Ohio
    Posts
    7,207
    Post Likes
    Where have you measured voltage and what were the readings?
    AOP Rules: Rules For Equipment Owners.

    Free online load calculator: http://www.loadcalc.net/


    There = not here. Their = possessive pronoun. They're = they are
    It's = contraction of it is. Its = the possessive form of it
    Too = also. To = expressing motion. Two = 2
    Then = after that, next. Than = indicates a comparison.
    Questions should end with a question mark "?" Statements end with a period "."

  9. #9
    Join Date
    Sep 2007
    Location
    edmonds wa
    Posts
    4,433
    Post Likes
    At 22 years old , do you have it serviced yearly? could be other issues causing your problem.
    UA Local 32 retired as of Jan 2020

  10. #10
    Join Date
    Mar 2013
    Location
    DeLand, Florida
    Posts
    33
    Post Likes
    Control voltage, maybe shorting out? Trace the t-stat wiring to the AH and then to the Cond.
    I love the line "Can you do it for cheaper?"

    I always say yes and leave.....

  11. #11
    Join Date
    May 2018
    Location
    VA/DC
    Posts
    304
    Post Likes
    Quote Originally Posted by Capt Wolf View Post
    Control voltage, maybe shorting out? Trace the t-stat wiring to the AH and then to the Cond.
    this is a solid starting point. when it shuts off does the compressor timer start? does it have batteries?

    I have had a bad contactor and every time it was energized the volts dropped enough to make the stat reset

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •