Results 1 to 5 of 5

Thread: Oil Odors

  1. #1
    Join Date
    Nov 2015
    Location
    MAINE
    Posts
    24
    Post Likes

    Oil Odors

    My JB 7cfm vacuum pump seems to have an odor like an expo marker or a sharpie. I change the oild after every 5 uses unless it is a really humid day than 3 uses. I have encountered this smell in some poe systems like minisplits after a burnout but never in my vacuum pump. The oil was slightly fogged and leaves a strange white film on the sight glass. Now the pump works great and i am still able to achieve a deep vacuum. Any help would be great.

  2. #2
    Join Date
    Jul 2018
    Location
    Wisconsin
    Posts
    1,103
    Post Likes
    Take the cover off and clean it. Change the oil when its hot.

    Sent from my SM-G960U using Tapatalk

  3. #3
    Join Date
    Nov 2015
    Location
    MAINE
    Posts
    24
    Post Likes
    Thread Starter
    Any recommendations on cleaning solutions to get rid of smell? I usually just dry with rag but its so strong i worry a bit that it might be acid. Thanks

  4. #4
    Join Date
    Jul 2018
    Location
    Wisconsin
    Posts
    1,103
    Post Likes
    I would hit it with some zipp spray from Rectorseal

    Sent from my SM-G960U using Tapatalk

  5. #5
    Join Date
    Nov 2015
    Location
    MAINE
    Posts
    24
    Post Likes
    Thread Starter
    Good deal thanks so much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •