Page 1 of 2 12 LastLast
Results 1 to 13 of 22
  1. #1
    Join Date
    Nov 2018
    Posts
    18
    Post Likes

    HSI glowing, gas to burners, will not light on the regular.

    Hot surface igniter glows, gas valve opens and lets gas in, does not always light.

    This unit has a sealed combustion chamber. Inlet and out let are clear and free flowing.

    New gas valve because last valve's regulator went bad and was pushing out 10wc (nat gas). This unit should be 3.5wc.

    The new valve is causing the same exact issue. Glow, gas, no light (sometimes it will, and it can be lit manually as well).

    Mind boggled!

  2. #2
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    24,377
    Post Likes
    Quote Originally Posted by RealRob View Post
    Hot surface igniter glows, gas valve opens and lets gas in, does not always light.

    This unit has a sealed combustion chamber. Inlet and out let are clear and free flowing.

    New gas valve because last valve's regulator went bad and was pushing out 10wc (nat gas). This unit should be 3.5wc.

    The new valve is causing the same exact issue. Glow, gas, no light (sometimes it will, and it can be lit manually as well).

    Mind boggled!
    Then it wasn’t the valve I guess!

    Sorry

    No DIY!

  3. #3
    Join Date
    Jan 2010
    Posts
    17,335
    Post Likes
    Sounds like a non converted LP setup.
    If so there's more to it.
    Not a good idea to play with a gas appliance that can kill.

  4. #4
    Join Date
    Nov 2018
    Posts
    18
    Post Likes
    Thread Starter
    Quote Originally Posted by VTP99 View Post
    Sounds like a non converted LP setup.
    If so there's more to it.
    Not a good idea to play with a gas appliance that can kill.
    This is a natural gas setup, always has been. New valve is nat gas (and it is, I dbl checked) and comes with lp conversion.

  5. #5
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    24,377
    Post Likes
    So what’s the incoming pressure?

  6. #6
    Join Date
    Nov 2018
    Posts
    18
    Post Likes
    Thread Starter
    Quote Originally Posted by pecmsg View Post
    So what’s the incoming pressure?
    Didn't bother to check the source, but to the burners it's 3.5wc.

  7. #7
    Join Date
    Jan 2010
    Posts
    17,335
    Post Likes
    What's the valve make/model ?

  8. #8
    Join Date
    Nov 2018
    Posts
    18
    Post Likes
    Thread Starter
    Quote Originally Posted by VTP99 View Post
    What's the valve make/model ?
    Robertshaw 722-079

    https://www.grainger.com/product/ROB...as-Valve-1TGD7

  9. #9
    Join Date
    Jan 2010
    Posts
    17,335
    Post Likes
    and the equipment make/model ?

  10. #10
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    24,377
    Post Likes
    Quote Originally Posted by RealRob View Post
    Didn't bother to check the source, but to the burners it's 3.5wc.
    So how does the valve “Increase” the pressure almost 3X?

  11. #11
    Join Date
    Nov 2018
    Posts
    18
    Post Likes
    Thread Starter
    Quote Originally Posted by VTP99 View Post
    and the equipment make/model ?
    Empire DV40
    http://empirezoneheat.com/products/d...wall-furnaces/

    Parts and exploded view
    https://empireheaterparts.com/pdf/dv20e-40e-55e.pdf

  12. #12
    Join Date
    Nov 2018
    Posts
    18
    Post Likes
    Thread Starter
    Quote Originally Posted by pecmsg View Post
    So how does the valve “Increase” the pressure almost 3X?
    I was saying that the old valve had a bad regulator and was pushing out ~10wc

  13. #13
    Join Date
    Jan 2010
    Posts
    17,335
    Post Likes
    So why didn't you buy the 722-052

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •