Page 1 of 2 12 LastLast
Results 1 to 13 of 16
  1. #1
    Join Date
    Oct 2019
    Posts
    10
    Post Likes

    Rising CO levels--Oil to gas conversion boiler

    I have a Weil-McLain boiler installed in 2008 that was converted from heating oil to gas in 2014. This boiler runs a 1920s steam heating system. I had an energy audit done in April and was advised that the boiler was producing too much CO at the flue (over 1000ppm). I had a technician come in and he adjusted the flame and oxygen level and brought it down to 85ppm in May.

    The energy efficiency contractor comes today to do an insulation blow-in and remeasures the boiler CO and it comes in at 700ppm. No one has touched or adjusted the boiler between May and today.

    Can you give me some advice on what could cause this so I can make sure this gets fixed once and for all?

    And can anyone refer me to someone in the Central Massachusetts area who has expertise in correcting this kind of problem on a steam system?

  2. #2
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    24,414
    Post Likes
    For the Boiler you need someone trained by NCI in combustion analyses. Look on there web site.

    For Steam Heating Help Dot Com

    The Wall
    They also have a contractors search area.

    New England steam works is one of the best but almost impossible to get due to demand.

  3. #3
    Join Date
    Jan 2012
    Location
    Broomall, PA
    Posts
    2,725
    Post Likes
    Seems like the last technician knew what he was doing, get him back. Equipment, especially steam, needs at least annual attention. There's no such thing about fixing combustion 'once and for all'. It's like checking your heart and saying it's fine 'now and forever'.

    As far as CO, could be as simple as annual maintenance and cleaning dust off/out of the power burner. A burner in a basement is subjected to dirt and dust from things like having a workshop, to dryer lint, both affecting combustion air and by extension combustion.
    Could be something blocking/lodged in your flue.
    Could be sediment in the gas line affecting flow.
    Could be you tightened up your house, and now you are robbing the burner of combustion air.
    If I do a job in 30 minutes it's because I spent 30 years learning how to do that in 30 minutes. You owe me for the years, not the minutes.

  4. #4
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    24,414
    Post Likes
    How long was the unit running before they checked?

  5. #5
    Join Date
    Oct 2019
    Posts
    10
    Post Likes
    Thread Starter
    I'm not 100% certain as my spouse was there not me. He turned it off and then turned it back on to retest, but still came back high

  6. #6
    Join Date
    Dec 2014
    Posts
    2,850
    Post Likes
    Like Steve said, probably a really good idea to get that first guy back. Then post pics of the install pics of the chimney and termination and pics of his test points and while you're at it a pic of the combustion analysis print out.
    This could easily get bad in a hurry so I would suggest that this be a priority for you.
    Don't run the equipment until somebody is there that knows how to set this up.

    2 questions. Although 700 PPM is too high anyhow, was the measuring done on a cold start?
    Also, did the ppm rise during testing or remain steady? (Same ? for the time it was recorded at 85ppm)


    Sent from my SM-G950U using Tapatalk

  7. #7
    Join Date
    Oct 2019
    Posts
    10
    Post Likes
    Thread Starter
    I will do this and post back to the forum--I'm not sure if its a cold start or after running for a bit. I have indirect hot water so the boiler is almost always on. The CO detector right above the boiler is not going off. It seems that its definitely going up the flue.

    What causes the ppm to go up. If he adjusted it in May, why would it go to 700ppm in just a few short months?

  8. #8
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    24,414
    Post Likes
    Forget the detector above. By the time that alarms you’ve got bigger issues. Search Low Level CO Detectors.

  9. #9
    Join Date
    Oct 2019
    Posts
    10
    Post Likes
    Thread Starter
    So I have to post 7 times to post links to photos. So sorry friends....Gonna make a few posts to reach that point

  10. #10
    Join Date
    Oct 2019
    Posts
    10
    Post Likes
    Thread Starter
    Posting again here.

  11. #11
    Join Date
    Oct 2019
    Posts
    10
    Post Likes
    Thread Starter
    Someone suggested the issue could be that the gas burner is the wrong size for the boiler. Could that be it?

  12. #12
    Join Date
    Oct 2019
    Posts
    10
    Post Likes
    Thread Starter
    Last one...

  13. #13
    Join Date
    Oct 2019
    Posts
    10
    Post Likes
    Thread Starter
    Last one again

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •