Results 1 to 6 of 6
  1. #1
    Join Date
    Nov 2016
    Posts
    14
    Post Likes

    Cornelius Ice Flaker

    Hey guys,

    I've got a Cornelius WCF-510A ice machine. We suspected a leak so we recovered the charge 24 oz. 404a changed the drier, pressure tested and then pulled a vacuum and put some new 404A in the system.

    Started it up and it makes ice within 1.5-2 mins. However the compressor is frosting up quite a bit in that time as well. I'm thinking that maybe my txv(non-adjustable) is not functioning properly?
    What do you guys think?

    Thanks!

  2. #2
    Join Date
    Jun 2006
    Posts
    1,299
    Post Likes
    That you shouldn't be working on it???

    Sorry couldn't resist.

    You didnt mention leak repair so no idea, what made you think it had one?

    Frost at the compressor means virtually nothing on a system designed to operate below freezing, subcooling and superheat mean lots more so your incomplete post can only lead to incomplete answers.

  3. #3
    Join Date
    Mar 2015
    Location
    Medford, N.Y.
    Posts
    6,122
    Post Likes
    A 1.5-2 min ice cycle????

  4. #4
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    25,776
    Post Likes
    Quote Originally Posted by TechmanTerry View Post
    A 1.5-2 min ice cycle????
    Yea

    2 Flakes!

  5. #5
    Join Date
    Oct 2009
    Location
    Atlanta,Ga.
    Posts
    526
    Post Likes
    the compressor is going to have some frost, there is cold suction gas coming back.Just make sure there is some superheat there(5-10 degrees) so you aren't flooding back.

  6. #6
    Join Date
    Jan 2010
    Posts
    18,094
    Post Likes
    Quote Originally Posted by TechmanTerry View Post
    A 1.5-2 min ice cycle????
    Man I gotta get one of those machines

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •