Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2004
    Location
    San Francisco Bay Area
    Posts
    556
    Post Likes

    Johnson York chiller - SC-EQ BACnet issue

    I've got the SC-EQ communication card working correctly on my BACnet MS/TP network, at least the addressing side of things - but a Niagara point discovery won't work. It shows the following error, which repeats into perpetuity..:

    Status Timestamp Message Details
    ------- ---------------------- -------------------------------------------------------------------------- -------
    Running 22-Jul-19 11:19 AM EDT Beginning object discovery...
    Message 22-Jul-19 11:19 AM EDT Object list size: 109
    Message 22-Jul-19 11:19 AM EDT Reading Object_Names...
    Message 22-Jul-19 11:19 AM EDT Reading Object properties...
    Message 22-Jul-19 11:19 AM EDT Error reading object values with single RPM message:REJECT:Buffer Overflow
    Message 22-Jul-19 11:19 AM EDT Reading object values in groups: items 0 to 0
    Message 22-Jul-19 11:19 AM EDT Reading object values in groups: items 1 to 0
    Message 22-Jul-19 11:19 AM EDT BacnetException reading group: REJECT:Missing Required Parameter
    Message 22-Jul-19 11:19 AM EDT Reading items individually for ids 1 through 1...
    Message 22-Jul-19 11:19 AM EDT Reading object values in groups: items 1 to 0
    Message 22-Jul-19 11:19 AM EDT BacnetException reading group: REJECT:Missing Required Parameter
    Message 22-Jul-19 11:19 AM EDT Reading items individually for ids 1 through 1...
    Message 22-Jul-19 11:19 AM EDT Reading object values in groups: items 1 to 0

    No point ever appears - it seems as though something fails at the beginning (is that a "ReadPropertyMultiple" error? how would I fix?), but I don't know if the problem is on the Niagara end, or on the SC-EQ end...
    Anybody every successfully integrated a York chiller with one of these cards?

  2. #2
    Join Date
    May 2019
    Location
    Jamestown, NY
    Posts
    68
    Post Likes
    I've integrated York chillers before, we had to get Johnson Controls to flash updated firmware. Their comm card was blocking us because we were asking for state text tables for all types of points (even those you normally wouldn't) and they were throwing errors. I'd call them first.

    Sent from my Pixel 2 XL using Tapatalk

  3. #3
    Join Date
    Sep 2013
    Posts
    237
    Post Likes
    I just integrated three YMC2 chillers and the enumerated points state text didn’t come through. I could see how many states they had but couldn’t discover the states text so we had to fat finger it.

    Point is there is maybe a not so good implementation of BACnet here. I wonder if JCI is using some proprietary properties on these BACnet points?


    Sent from my iPad using Tapatalk

  4. #4
    Join Date
    May 2019
    Location
    Jamestown, NY
    Posts
    68
    Post Likes
    It works perfect after the firmware update. It's anyone's best guess as to why it's implemented that way. Just don't wait to call them or it will just be expensive.

    Sent from my Pixel 2 XL using Tapatalk

  5. #5
    Join Date
    Jan 2003
    Location
    USA
    Posts
    4,571
    Post Likes
    Quote Originally Posted by davem View Post
    Message 22-Jul-19 11:19 AM EDT Error reading object values with single RPM message:REJECT:Buffer Overflow
    Guessing the Jace asked for the full list and the response was massive. Wads of points with tons of enum states and ignoring the Jace max message size maybe. It then seems to switch to polling smaller groups of properties as it should.

    Quote Originally Posted by davem View Post
    Message 22-Jul-19 11:19 AM EDT BacnetException reading group: REJECT:Missing Required Parameter
    Not sure who is reporting the missing parameter here.

    A capture would clear up who is putting crap on the line here.
    Propagating the formula. http://www.noagendashow.com/

  6. #6
    Join Date
    May 2019
    Location
    Jamestown, NY
    Posts
    68
    Post Likes
    What the regional JCI tech told me is that if the BAS system asks for an inappropriate state text table it will lock out communication. Our software apparently asks for a table for all points even though we really don't need them or care for a response. His first day he spent trying to get us to fix our software.

    Sent from my Pixel 2 XL using Tapatalk

  7. #7
    Join Date
    Dec 2004
    Location
    San Francisco Bay Area
    Posts
    556
    Post Likes
    Thread Starter
    Thanks for these great responses.... interestingly, after a couple dozen attempts, the Niagara point discovery finally auto-magically worked. Fortunately, contrary to bigguy's experience, all the enum state texts came in (York/JCI loves ALL CAPS, so I took the time to reformat them for a less vocal display of the status codes, etc.).
    Didn't need to update firmware, thankfully, and the comms are rock-solid now. I wonder if it was like MPeterson mentioned, where the board locked things up for a period of time, then decided to cooperate with whatever it was being asked...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •