Results 1 to 7 of 7
  1. #1
    Join Date
    May 2019
    Posts
    3
    Post Likes

    Triton T200 Boiler Error code.

    For 3 months now the boiler has been going into lockout code 109. I'm new to working on this boiler and have no clue where to start to get it to run. I have been told the Honeywell board is no good but cant find one to replace it with. Any help with this issue would be greatly appreciated.

  2. #2
    Join Date
    Jul 2018
    Posts
    50
    Post Likes
    Quote Originally Posted by timothy.murphy View Post
    For 3 months now the boiler has been going into lockout code 109. I'm new to working on this boiler and have no clue where to start to get it to run. I have been told the Honeywell board is no good but cant find one to replace it with. Any help with this issue would be greatly appreciated.
    According to the manual, it's an ignition failure. It says to check the following:
    1. Check pilot valve (Main Valve for DSI) wiring and operation -
    correct any errors.
    2. Check the fuel supply.
    3. Check fuel pressure and repeat turndown tests.
    4. Check ignition transformer electrode, ame detector, ame
    detector siting or ame rod position.
    5. If steps 1 through 4 are correct and the fault persists, replace
    the module.

    Sent from my SM-G960U using Tapatalk

  3. #3
    Join Date
    Jul 2018
    Posts
    50
    Post Likes
    Does it try to ignite? Does it fire up, for only a few seconds? Need more details...

    Sent from my SM-G960U using Tapatalk

  4. #4
    Join Date
    May 2019
    Posts
    3
    Post Likes
    Thread Starter
    Sometimes runs fine for a few days sometimes only couple hours. Some times cant get it to relive at all.

  5. #5
    Join Date
    Jul 2018
    Posts
    50
    Post Likes
    Quote Originally Posted by timothy.murphy View Post
    Sometimes runs fine for a few days sometimes only couple hours. Some times cant get it to relive at all.
    Did you see my previous reply? Go through those steps and let me know what you find.

    Sent from my SM-G960U using Tapatalk

  6. #6
    Join Date
    May 2019
    Posts
    3
    Post Likes
    Thread Starter
    yes sir working through that list now. at the moment im also being told that the honey well board is no good. so we shall see.

  7. #7
    Join Date
    Dec 2004
    Location
    Chicago area
    Posts
    7,586
    Post Likes
    Always start by doing maintenance on the burner, pilots, flame rods, ignitors, etc...


    Sent from my iPhone using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •