Results 1 to 8 of 8
  1. #1
    Join Date
    Jan 2017
    Posts
    10
    Post Likes

    Navien NCB-240 BLEW!!!

    Came home to my Navien blr blowing city pressured water out of the cabinet. Shut water off and fnd that the water was coming from the cold domestic side inlet. Further investigation showed that a hole had been blown from a plastic cap located on top of the plastic inlet tee that connects to the flow sensor located in the boiler. Anyone ever seen this before or know what the cause was. Pretty unhappy that my first day with my newborn son was spent trying to get heat and hot water on in my hse. Also this issue ended up flooding my downstairs. Need some ammo before calling up Navien.

    Key info
    -blr under warranty still
    -blr Installed to manufactured specs
    -I get city water and it’s pretty clean up here in AK
    -did have pressure relieve on domestic side
    -water was static when blow (no one home when issue occurred)
    Last edited by BAMSTER04; 04-14-2019 at 03:32 PM. Reason: Added blr make

  2. #2
    Join Date
    Jan 2017
    Posts
    10
    Post Likes
    Thread Starter
    Do have photos if anyone knows how to upload them

  3. #3
    Join Date
    Dec 2002
    Location
    SouthEast NC ICW & Piedmont Foothills
    Posts
    7,788
    Post Likes
    How many forum are you going to put this in? One should be sufficient.
    It`s better to be silent and thought the fool; than speak and remove all doubt.

  4. #4
    Join Date
    Jan 2017
    Posts
    10
    Post Likes
    Thread Starter
    Enough to get an answer rather than a remark.

  5. #5
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    20,380
    Post Likes
    Quote Originally Posted by BAMSTER04 View Post
    Enough to get an answer rather than a remark.
    Let us know how it goes with the factory!

  6. #6
    Join Date
    Jan 2017
    Posts
    10
    Post Likes
    Thread Starter
    Going to try and get ahold of the northwest rep first then go to the factory. Just wanted to see if anyone’s ever had this oddball issue with Navien or any other boilers using plastic fittings

  7. #7
    Join Date
    Mar 2010
    Location
    Rochester, NY
    Posts
    737
    Post Likes
    Have you done any work to it lately?
    I had that happen after changing a flow sensor because a clip didn’t seat right.

  8. #8
    Join Date
    Jan 2017
    Posts
    10
    Post Likes
    Thread Starter
    Replaced the 3-way diverting valve 5 months ago but no have not messed with the flow sensor or it’s assembly. It looks like a bullet hole went through that cap.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.