Results 1 to 4 of 4

Thread: Ultra 550

  1. #1
    Join Date
    Jul 2018
    Location
    Wisconsin
    Posts
    1,103
    Post Likes

    Ultra 550

    I service two Ultra 550s they do not hold there date/time when the power is cycled. I do not see any coin cell battery to replace. They hold all other settings and dealer information. Thinking its the display board. Both Main and shadow boiler have the same issue. Ultra 550 series1 about 5 years old.

  2. #2
    Join Date
    Dec 2004
    Location
    Chicago area
    Posts
    8,742
    Post Likes
    Seems like a non-issue.

    I would not rush to condemn the boards from the loss of date and time.

    I cant say one way or another whether or not there is a battery back up.

    Id put a call in to the local rep for Weil Mclain

    But either way - it every other function does as it should - I would not be worried about it.




    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Jul 2018
    Location
    Wisconsin
    Posts
    1,103
    Post Likes
    Thread Starter
    Yea its been that way for years. Every time I am there it seems to think its 2008. Not a big deal just a annoyance.

  4. #4
    Join Date
    Dec 2014
    Posts
    2,952
    Post Likes
    Every Ultra I've worked on is the same way. Set date and time, cycle power, reverts to 2008. Tech support had nothing to offer .

    Sent from my SM-G930V using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •