Results 1 to 4 of 4

Thread: Trane RTHB

  1. #1
    Join Date
    Apr 2011
    Location
    Southern Indiana
    Posts
    91
    Post Likes

    Trane RTHB

    Has anybody ever had to replace the motor temperature sensor terminals on this chiller? I have one that is leaking from the terminals and trying to see if anyone can give me some ideas.

  2. #2
    Join Date
    Feb 2017
    Location
    New York
    Posts
    1,095
    Post Likes
    Never have on those. I'm pretty sure it's just a stud through the middle. Same connections on both ends.
    Pump down and recover to slightly positive and change quickly. Pre-dope the threads to save time. Make sure to use a 6pt socket on those. It'll keep the stress off the epoxy in the middle.
    -----Stop, step back, relax and have another go at it.-----

  3. #3
    Join Date
    Apr 2011
    Location
    Southern Indiana
    Posts
    91
    Post Likes
    Thread Starter
    Yup, they all rusted out and were leaking. Had to move the starter cabinet out of the way and take the end bell off the economizer. Pretty time consuming because we had to use an easy out to take out the rest of th hex part of the terminals that had broken off inside.

  4. #4
    Join Date
    Feb 2017
    Location
    New York
    Posts
    1,095
    Post Likes
    Very rotted! Sorry for the delay, was browsing and came across this. Glad you were able to get it done!
    -----Stop, step back, relax and have another go at it.-----

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.