Results 1 to 13 of 13
  1. #1
    Join Date
    Apr 2013
    Location
    In a noisy mechanical room
    Posts
    46
    Post Likes

    York YK Microboard upgrade issues

    So I installed the optiview microboard retrofit kit 031-03630-001 on a YK chiller to replace the existing microboard.
    Followed the enclosed instructions and applied power.
    The screen displays the York logo and the progress bar. The progress bar loads up to about 99% and does nothing else. The aplha numerical led display on the microboard itself shows "SH"..
    Anyone run into this or have any suggestions?

    Thank you

  2. #2
    Join Date
    Apr 2013
    Location
    In a noisy mechanical room
    Posts
    46
    Post Likes
    Thread Starter
    Nevermind, I figured it out.
    In other news, Im an idiot


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Apr 2017
    Location
    The Deep South
    Posts
    374
    Post Likes
    It happens to all of us. I did this kit back in July and couldn't get it to see the VSD. Chased my tail for a while before I realized that the Comm protocol kept reverting back to "York" after I changed it to "ModBus". Simple fix once I removed my head from my backside.

  4. #4
    Join Date
    Apr 2013
    Location
    In a noisy mechanical room
    Posts
    46
    Post Likes
    Thread Starter
    My first time loading the software in the microboard. I misread the instructions and thought it said sw1 through 4 all need to be on, instead of the proper way of just #4 on sw1 turned on.


    Sent from my iPhone using Tapatalk

  5. #5
    Join Date
    Dec 2005
    Location
    Anaheim, Ca.
    Posts
    52
    Post Likes
    I'm doing a similar retrofit, but I'm not communicating on the Modbus. This MV-SSS has the older 031-02873 board. I'm trying to understand line 14 where is says to connect the 12vdc + to the starter. Whatever for?

  6. #6
    Join Date
    Dec 2005
    Location
    Anaheim, Ca.
    Posts
    52
    Post Likes
    What did you do in regards to connecting the Modbus to the Starter? I think the instructions are wrong regarding connecting 12v to the comm.

  7. #7
    Join Date
    Dec 2005
    Location
    Anaheim, Ca.
    Posts
    52
    Post Likes
    Ok, so I found a Benshaw manual, worked out the Modbus issue and I'm ready to start the beast. The problem I'm having now is since the BRAM went dead on the original board, the sales info is blank. I can't get to the box to enter the motor information. The panel doesn't like the 0228 password, so I need to get an admin password (I believe) The default is 19 to 65 amps.

  8. #8
    Join Date
    Aug 2006
    Location
    Mixing oil and fire with a big spoon.
    Posts
    6,893
    Post Likes
    Is this on the 3630 board you upgraded to? You should be able to get to all of the Sales order into unless you pressed the “finish setup” button.
    "Right" is not the same as "Wise".

    Don't step on my favorite part of the Constitution just to point out your favorite part.

  9. #9
    Join Date
    Dec 2005
    Location
    Anaheim, Ca.
    Posts
    52
    Post Likes
    so I ended up calling Benshaw to program the control board in the MVSSS, as it sends the information about the starter size to the Optiview. Then I called one of my buddies and he got me an Admin password so I could fill in all the Sales Info, Motor Info, etc... Finally started the chiller. Thanks for your help!

  10. #10
    Join Date
    Dec 2019
    Posts
    6
    Post Likes

    Help needed

    Quote Originally Posted by acrefertech View Post
    So I installed the optiview microboard retrofit kit 031-03630-001 on a YK chiller to replace the existing microboard.
    Followed the enclosed instructions and applied power.
    The screen displays the York logo and the progress bar. The progress bar loads up to about 99% and does nothing else. The aplha numerical led display on the microboard itself shows "SH"..
    Anyone run into this or have any suggestions?

    Thank you
    Hello, would you happen to have the form number. York did not send me any info and the book I have is outdated. Thank you

  11. #11
    Join Date
    Dec 2005
    Location
    Anaheim, Ca.
    Posts
    52
    Post Likes
    For the Micro Board retrofit?

  12. #12
    Join Date
    Dec 2019
    Posts
    6
    Post Likes
    Yes please. I only have the 160.54-m1 manual from 2013 and I install this micro board back in 2016/2017 and I did not keep the piece of paper they sent with the Micro board. There is a new SD card that came out and I need to load the new SD card in the micro board but my old manual was for the 024 board.

  13. #13
    Join Date
    Dec 2005
    Location
    Anaheim, Ca.
    Posts
    52
    Post Likes
    Lets see if this attachment goes with the reply. If not, I can email it to you

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •