Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2009
    Location
    Wa
    Posts
    442
    Post Likes

    Mobile device issues AX

    I have encountered something I don't understand?? I have a customer using a microsoft surface to access his HVAC. While on-site and connected to his LAN he logs in as a basic wb user and everything works great. When he logs in offsite using an extrenal IP address the hx profile is automatically chosen during connection. With a lot of drop down menus, and no right click functionality navaigation is impossible. I can't get mind around why accessing from an extrenal IP chooses the hx profile, and when connected on his companies LAN the px profile works fine.

  2. #2
    Join Date
    Mar 2016
    Location
    Queensland
    Posts
    209
    Post Likes
    Have you checked his user account settings? I'm thinking when he's on site he's connecting via a wired network & it's using the primary web settings, then when he's away from site connecting externally it's using the mobile settings?

    Here's a picture of how N3.8 presents the options.


  3. #3
    Join Date
    Mar 2016
    Location
    Queensland
    Posts
    209
    Post Likes
    Blasted photo hasn't attached! Here it is:


  4. #4
    Join Date
    Mar 2016
    Location
    Queensland
    Posts
    209
    Post Likes
    Hmm, weird! Maybe I can't post pictures?

    So in the user account settings there's a default web profile & a mobile web profile.

    I'm betting he's using one internally, and the other externally & they're not both set up the same way.

  5. #5
    Join Date
    Feb 2013
    Location
    North Carolina
    Posts
    70
    Post Likes
    Sounds like Tridium is seeing his device as a mobile when coming through the external IP. If you set the mobile web profile for that user to the same as the regular web profile it should fix the problem.

  6. #6
    Join Date
    Jul 2009
    Location
    Wa
    Posts
    442
    Post Likes
    Thread Starter
    Guys thanks for the response. He is using one user account only. In the web profile he's set for basic wb web profile. The mobile profile he's set for basic hx profile. No choice for the basic wb web profile in the mobile menu. Which makes sense. What doesn't is why when logging in remotely the system thinks his device is a mobile device, and when connected on their local LAN it logs in just fine. My work around at this point is VPN to my server machine and have him login there. I ran into this awhile back on a windows 8.1 laptop that was full size. But every time I logged in the system would choose the HX profile. Not sure if 8.1 had tablet view or not?? Maybe that's all that was?? My solution there was just use the HX profile.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Contracting Business
HPAC Engineering
EC&M
CONTRACTOR