Results 1 to 9 of 9
  1. #1
    Join Date
    Apr 2008
    Location
    Tucson, AZ
    Posts
    299
    Post Likes

    Carrier, defrost and freeze stat.

    RTU freeze stat had opened during defrost cycle. So compressor is off, Blower runs and makes the room even colder, 50*. Ambient 29*F. Jumped out freeze stat for awhile and started heating. 10 minutes in, freeze stat closed again, unit goes into defrost and indoor coil again gets below freezing. Turned it off for a couple hours as I was busy elsewhere. When I returned it was working fine, ambient 45*f. Room 72*f, Carrier says unit is good down to 25*f. No aux heat.
    Carrier, 50TCQA07A2A6A0A0A0, S#4411C80330.
    I need to go back and do some finer troubleshooting; just getting some ideas.
    Is it normal for a freeze-stat to trip in defrost?

  2. #2
    Join Date
    Sep 2007
    Location
    edmonds wa
    Posts
    4,134
    Post Likes
    Do you have to much fresh air setting or is the econo driving open during defrost?
    UA Local 32

  3. #3
    Join Date
    Apr 2008
    Location
    Tucson, AZ
    Posts
    299
    Post Likes
    Thread Starter
    Quote Originally Posted by buford View Post
    Do you have to much fresh air setting or is the econo driving open during defrost?
    I believe it is 5% minimum approx.

  4. #4
    Join Date
    Sep 2007
    Location
    edmonds wa
    Posts
    4,134
    Post Likes
    Is the defrost stat in the right spot? Freeze stat is on the indoor coil, so yes during defrost that coil could drop the temp down, until the outdoor coil temp gets warmer. I have seen units with either too much outdoor air or the econo open during a cooling with compressor also trip them.
    UA Local 32

  5. Likes mccann liked this post
  6. #5
    Join Date
    Apr 2008
    Location
    Tucson, AZ
    Posts
    299
    Post Likes
    Thread Starter
    Quote Originally Posted by buford View Post
    Is the defrost stat in the right spot? Freeze stat is on the indoor coil, so yes during defrost that coil could drop the temp down, until the outdoor coil temp gets warmer. I have seen units with either too much outdoor air or the econo open during a cooling with compressor also trip them.
    Ay, if the room is cold and cold outside it may be hard for that stat to close again. I assume it closes back around 45*f, but it's a klixon not a precision instrument. It would be nice to kick it back into heat in such a moment instead of just shutting off the compressor, Alas. Perhaps it stuck in defrost too long causing the too cold sequence.

  7. #6
    Join Date
    Sep 2007
    Location
    edmonds wa
    Posts
    4,134
    Post Likes
    Is the charge good?
    UA Local 32

  8. #7
    Join Date
    Apr 2008
    Location
    Tucson, AZ
    Posts
    299
    Post Likes
    Thread Starter
    Quote Originally Posted by buford View Post
    Is the charge good?
    Good point. I did not have time to check the charge when I was there, but I certainly will.
    Question: If charge is low and I'm in heat; then in defrost; would that effect defrost termination or are you saying the indoor coil would get too cold in defrost because of that? Defrost is a max of ten minutes I think, unless the termination stat closes right? When it went into defrost, the outdoor coil got very warm so I was thinking perhaps the termination stat was sticking. I wish I had more time that day. I only had 15 minutes on the unit, alas.

  9. #8
    Join Date
    Jan 2017
    Location
    SE Ohio
    Posts
    26
    Post Likes
    Like Buford said, check charge.

    Also check for txv on inddor coil. If it is restricting, and your freeze stat is close to distributor tubes, that (36 F ?) stat will open quickly. Let us know what you find.

  10. #9
    Join Date
    Apr 2008
    Location
    Tucson, AZ
    Posts
    299
    Post Likes
    Thread Starter
    Quote Originally Posted by RV10flyer View Post
    Like Buford said, check charge.

    Also check for txv on inddor coil. If it is restricting, and your freeze stat is close to distributor tubes, that (36 F ?) stat will open quickly. Let us know what you find.
    I thank you all for your assistance. Alas. One of our other tech's want back because I was too busy. He changed the defrost board and outdoor stat, as that was my first guess before getting to put put gauges on it and talking to you folks. It's working now possibly because it's been warm at night. I doubt he did any further analysis. If I am on that building again this winter, I want to look into it more. Sometimes though I may not go back to a location for a year. Frustrating.
    Thank you all again for your knowledge.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •