Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2019
    Posts
    7
    Post Likes

    Fieldpiece Job link proves

    Hi all,

    So I just received a set of the Job Link probes from Fieldpiece. They seem really cool for the most part, but I have a question for those of you who also have them. Are the fittings on the pressure probes slightly shallow, as in not as deep as normal hose fittings? I had a really hard time getting them attached to my unit at the house and finally realized that there doesn’t seem to be as much thread as on normal hose fittings...not sure if it’s just me not being used to them or what?

    Also, how prevalent are the connection issues? As in the connecting and reconnecting? I had some issues, but not terrible, I was also going through a stone wall. My iPad seemed to have slightly less trouble though so maybe it’s just my phone? I plan to try measurequick as well but didn’t get to yet.

    Looking forward to all feedback!


    Sent from my iPhone using Tapatalk Pro

  2. #2
    Join Date
    Jul 2016
    Location
    Tahoe
    Posts
    46
    Post Likes
    I don't have a set of those, but.. 1) make sure the o-rings are seated down well 2) check that the schrader depressors are screwed in well 3) if you want to compare to your manifold hoses, just count the exposed threads and then let us all know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •