Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2015
    Posts
    1
    Post Likes

    Water furnace not cooling house adequately

    I have a Water Furnace Premier and over the last couple of days it is not cooling the house properly. It runs constantly and blows cold air but does not cool the house. The temperature on the thermosat will gradually rise. I have changed the filter and status lights on the furnace are green. Any help would be appreciated.

  2. #2
    Join Date
    Jan 2015
    Location
    Bellevue, Washington, United States
    Posts
    1,643
    Post Likes
    Maybe close your windows????

    Just joking. Well you're going to start by checking your temperatures. The air on the supply registers should be at least 30 degrees cooler than the air inside the home. You'll have to check several other things if the temp isn't low enough, but that's something a tech will need to do.....

  3. #3
    Join Date
    Feb 2009
    Location
    Portland OR
    Posts
    2,616
    Post Likes
    You need to have a tech come out. A lot of the Premier units no longer have OEM compressors available so take care of that system or you will be buying a new one soon.

    I see a lot of refrigerant leaks on systems in the 15+ year range, however a slew of diagnostics should be done before putting gauges on the system, because the geothermal units are very specific in their charge and even with low loss fittings refrigerant will come out when gauges are hooked up which is why WaterFurance does not recommend using gauges unless a low charge is the only potential issue.
    Check out my YouTube channel - http://www.youtube.com/user/skyheating1 We have customer testimonials, product reviews and more!
    Like us on FACEBOOK if you like our advice here!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •