Results 1 to 7 of 7
  1. #1
    Join Date
    Apr 2015
    Location
    South Carolina
    Posts
    20
    Post Likes

    problems with pre-rotation vanes actuator on yk chiller

    Has anybody had any problems with the PRV's on York YK chillers? I have had two go out because of
    gears locking up and the latest one to replace the last came in DOA. The field coil was open right out
    of the box. Chiller is only 5 years old.

  2. #2
    Join Date
    Dec 2014
    Location
    New Mexico
    Posts
    991
    Post Likes
    Only problems that we have seen here were two that would not stop rotating at the close position. Very weird to stand there and see arm going around in circles. That was only on two out of 150 YKs. All way out of warranty .


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    May 2015
    Location
    North NJ
    Posts
    6
    Post Likes
    Sounds pretty uncommon.

  4. #4
    Join Date
    Nov 2019
    Posts
    2
    Post Likes
    I have one now on the second actuator and about to replace that one as well. 5 years old

  5. #5
    Join Date
    Nov 2011
    Location
    East Side
    Posts
    7,062
    Post Likes
    Are the actuator motors hitting their internal stops before the vane arm starts to bind?

  6. #6
    Join Date
    Aug 2019
    Location
    LA
    Posts
    32
    Post Likes
    Yes. There was a bad batch that were failing often. Part numbers didn’t change so good luck

  7. #7
    Join Date
    Nov 2019
    Posts
    2
    Post Likes
    They sent us another and like you said same part number. I guess we'll see. This machine has been checked top to bottom by Johnson and another chiller company. No solution. Running good again for now.

    Sent from my SM-N975U using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •