Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2008
    Location
    DFW,TX
    Posts
    4,060
    Post Likes

    fieldpiece SRL8 charging and changing tip filter issues?

    ok ive had this leak detector less then a year and used it maybe 10 x now , seems like a good meter but really its had this charging issue almost from the beginning.. i found it weird that the prt that plugs into meter from the 120v wall plus never bottomed out as it doesnt go all the way in, i just moved it around until the light came on to charge..now it wont even do that. i know its not fully discharge but ive used it twice for long periods so i know it needs alittle charge but i cant get light blink for charge indication to even start..arghh.. is this normal??

    also how in the heck do you get the filter out of the tip i tried removing the tip off of wand then tried to push pull or drag that filter out but it appears maybe the top end of tip unscrews but it wont budge and i dont want to break it, anybody have aquick answer for this filter removal??

  2. #2
    Join Date
    Nov 2015
    Location
    Destin, FL
    Posts
    26
    Post Likes
    Tip unscrews, push old filter out, put new filter in, screw back on.

    Don't forget to wrap the tip you just removed with blue painters tape as that will help with reducing false hits. Electrical tape or duct tape is bad as it will set off meter.

    Also, hold down the auto zero and it will turn of the auto zero. you will have a low tolerance to refrigerant concentration helping you find leak faster. Pushing the auto zero when of will rest to new level if in higher concentration.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •