Page 1 of 2 12 LastLast
Results 1 to 13 of 15

Hybrid View

  1. #1
    Join Date
    Oct 2011
    Location
    Idaho
    Posts
    6

    Confused Carrier Danfoss Compressor failures

    Hello fellows, I would like to ask for responses from all techs that have had compressor failures on Carrier Aquasnap 30RB100 or simular chillers with Danfoss compressors. We have installed or have been involved with 3 of these chillers. All three have had one or two mechanical compressor failures just out of warranty each time. A total of 5 compressors from 3 units! Whats up? Over $6000.00 apiece for compressors. We have gotten the too bad sorry from our Carrier reps! Any ideas on what to do?

  2. #2
    Join Date
    Jan 2008
    Location
    Dallas ,Texas
    Posts
    3,718
    What year model are these chillers?
    UA 100

    It takes three people to do anything around here. Two do the work, one explains to the crowd of people who showed up when they seen smoke and flames.

  3. #3
    Join Date
    Oct 2011
    Location
    Idaho
    Posts
    6
    They are 2006 models

  4. #4
    Join Date
    Oct 2011
    Location
    Idaho
    Posts
    6
    Two of them were built within 3 weeks of each other. Two of the compressors are 5 units apart.

  5. #5
    Join Date
    Aug 2002
    Location
    Greenville SC
    Posts
    432
    Make sure the setpoint for the suction superheat in the comfiguration menu is set to nine degrees. Some of the early Snaps were set at seven which is to low. Whats your
    leaving chill water temp?

  6. #6
    Join Date
    Oct 2011
    Location
    Idaho
    Posts
    6
    48 degrees

  7. #7
    Join Date
    Dec 2010
    Location
    Central US
    Posts
    417
    What type of compressor failure? Faulty windings to ground or what? Had 1 that lost 7 out of seven within a week of each other 2 months out of warranty. ended up changing driers, oil and refrigerant as well as superheat setpoint as mentioned before. And carrier recomended strangley all seven contactors which ended up being physically larger and higher in amp rating. Hmmmmmm. 2 years later 3 months ago all 4 compressors circuit A all shorted to ground randomly with in 2 weeks. B circuit still humming along.

  8. #8
    Join Date
    Oct 2011
    Location
    Idaho
    Posts
    6
    The compressor have either locked rotor or run but do not pump. This is a real bummer because it seems as though the choice to use the scrolls mat not be the wisest. The old 06's ran forever. Bill

  9. #9
    Join Date
    Aug 2002
    Location
    Greenville SC
    Posts
    432
    With the new refrigerants that they want to use, it is either scrolls or screws. I sure miss the 06E's.

  10. #10
    Join Date
    Jan 2008
    Location
    Dallas ,Texas
    Posts
    3,718
    Another option would be to upgrade the SPM boards, lots of goodies added to them since your chiller was made if none have been replaced. I'd prefer a recip over a scroll any day but we are moving forward not backwards with technology.
    UA 100

    It takes three people to do anything around here. Two do the work, one explains to the crowd of people who showed up when they seen smoke and flames.

  11. #11
    Join Date
    Oct 2011
    Posts
    40
    I have a 2005 30RB160[7 compressors] and since install, have replaced 12 compressors, what to do?

  12. #12
    Join Date
    Aug 2002
    Location
    Greenville SC
    Posts
    432
    What kind of Expansion Valves are on these chillers?

  13. #13
    Join Date
    Oct 2011
    Posts
    40
    I have electronic X-Valves, don't know the brand off the top of my head.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event