Results 1 to 13 of 13

Thread: Stumped

  1. #1

    Question

    Trying to repair a Lennox G26 with intermittent pilot ignition. When igniting, I get spark but it acts like it's not getting gas, or that there's air in the line. The ONLY thing that works is to take off the combustion box cover. Then the pilot lights with no trouble. Here's a list of what I've done so far:

    Cleaned/replaced flame sensor
    replaced ignition module
    replaced control board
    cleaned pilot valve and orofice
    checked for proper voltage to pilot valve, main valve
    checked for gas flow from pilot valve
    disconnected intake pipe- makes no difference
    pressure switch is good
    ?????????????????????????????????????????????????? ???????

    I suspect a crack in the heat exchanger even though I don't see any evidence of that. I have seen 80% furnaces with a crack near the burner and it disrupts the flame, but preventing the pilot from lighting?? Removing the intake pipe makes no difference. Only taking the cover off the combustion box. If the exhaust is plugged, the pressure switch would prevent any ignition at all.
    Would really appreciate some good advice!
    Thanks

  2. #2
    Join Date
    Jul 2003
    Posts
    48
    try checking the pilot gas pressure. Is this a propane fired unit? tank pressure can change. If you live in a cold climate check the gas regulator outside for proper venting. I have seen ice block the vent and cause pressure problems.

  3. #3
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    67,910
    Register as a pro, were not allowed to answer questions like that in the resi forum.
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  4. #4
    Join Date
    Nov 2001
    Posts
    1,874
    Are you sure it's a G26,
    I saw most to have a hot surface ignitor.
    If you try to fail, and succeed.
    Which have you done ?



  5. #5
    Join Date
    Apr 2003
    Location
    Eugene, Oregon
    Posts
    1,209
    Birds
    Proud supporter of Springfield Millers and Oregon Ducks.

  6. #6
    Join Date
    Mar 2005
    Location
    burlington county n.j.
    Posts
    9,739
    Originally posted by Toolpusher
    Are you sure it's a G26,
    I saw most to have a hot surface ignitor.

    original g26 heaaters had that pos johnson blue box.

  7. #7
    heat&blow is offline Professional Member-BM-bad email, server rejected
    Join Date
    Jan 2006
    Posts
    24
    Rubber gasket where the the pta assy, goes it isn't air tight, make sure the plate of the comb. Box is in properly and tightened, make sure the pilot assembly is tightened on the burner holder evenly. And there is most likely a crack in the h/e on the top part about half way in, good luck

  8. #8
    Join Date
    Mar 2005
    Location
    Suppy NC
    Posts
    4,513
    there is a screen where the intake pipe comes into the burner box. more then likely it is covered with debree

  9. #9
    Join Date
    Dec 2005
    Posts
    94
    Had this happen to a couple of units, but intermittently, when the G26 first came out. Failure to light pilot one out of maybe ten trials. After trying some of those other things I replaced the pilot assembly. That did it. Not exactly sure why.

  10. #10
    Thanks to all for the advice. The customer put me off until Monday, so I'll let you know what happens.

  11. #11
    Finally figured it out. Tried to adjust the pilot pressure and nothing happened. Replaced the gas valve and it works fine.

  12. #12
    Join Date
    Jan 2006
    Posts
    1

    Question

    its been awhile since ive worked on res equipement.if it pvc exhaust pipes try reducing air intake.like from 3 to 2 at termination.or play with it with a piece of duct tape over end of pipe ,to see if this would help.

  13. #13
    Join Date
    May 2004
    Posts
    11,999

    Due to our Forum Rules we are not allowed to discuss step by step instructions or repairs in this area.

    If you are a professional in our field please register as such and fill in your credentials. We can discuss technical issues only in the Pro Forums.

    thx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event