Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2005
    Posts
    156

    Hmm McQuay-ACZ020AC12-ER10-Failing

    We have a Library and the Admin section is cooled by a McQuay Split System--The outside unit is a McQuay-ACZ020AC12-ER10--Continually Failing on High Cond Press or MHP or High Motor Temp.
    The Condenser Coil has been cleaned numerous Times--Coil Superheat adjusted to 12 Degrees SH and we are getting 18 Total SH at Compressor--Subcooling at 16 Degrees--Pressures appear to be normal--This unit has a HG Bypass--set to come in at 59 and shut off at 64-Working good--We are thinking possibly a defective sensor -----Has anyone experienced this in their Buildings.
    Attached Images Attached Images   
    Last edited by hvactech80; 10-01-2011 at 04:17 PM. Reason: need to add another picture

  2. #2
    Join Date
    Aug 2010
    Location
    N.E Ohio
    Posts
    15
    Compressor motor protector defective.

  3. #3
    Join Date
    Mar 2009
    Location
    Mid-Mo
    Posts
    3,594
    I'm with him on motor protector. Take the peckerhead covers off and look for where water might have gotten into the module. I will drill an 1/8" hole in the bottom of the plastic to let the water drain out. See it a lot on the AGZ chillers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event