Liebert Mini-Mate2 not dehumidifying now after 4 years of use
Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2011
    Location
    North Bend, WA
    Posts
    1

    Confused Liebert Mini-Mate2 not dehumidifying now after 4 years of use

    First off, this is the scenario:
    8x8x16 room, good vapor barrier.Room only opened 2-4 days per week,and 4-8 times on those days.
    21C +/-1C
    35% +/- 3%
    Condensing unit: MMO12E-PA50A
    Air Handler: PEH014A-P3L
    Precision weighing lab with 20-23C, 30-40% requirements.
    Unit has been able to keep these conditions over the past 4 years with very few exceptions: high ambient temp days, refrigerant leak, etc.

    Recently over the past few months the unit has not been able to pull humidity out of the room below about 36% and currently has difficulty getting much below 40%. In the past I could set the unit to 30% or less as a test and it could handle the task. Now, no matter what humidity point I set (that is below 35%) the room will not get below 36-37% humidity. The temperature control has been working fine keeping the temp at 21.7C +/- 0.5C.

    I have had an HVAC service tech come out to troubleshoot only to tell me that nothing is wrong with the unit. I know that there IS something wrong because the unit will not pull out any more humidity out of the room. I just don't know what the problem is. I would appreciate any help with identifying a solution to the problem.

  2. #2
    Join Date
    Oct 2004
    Posts
    28
    As per the AOP Rules only Professional Members * can reply with advice to the OP. Anyone may post and ask questions. They may even question the * member answer but not give advice or expand on the advice given. Please read these rules for a complete understanding. AOP Rules

    For those in our industry who wish to become a Professional Member, please click here and follow the instructions. Apply for Professional Membership
    Last edited by Chris_Worthington; 09-24-2011 at 03:49 PM. Reason: Per Above

  3. #3
    Chris_Worthington's Avatar
    Chris_Worthington is offline Controls Committee & Global Moderator
    Join Date
    Jul 2007
    Location
    Mount Airy, MD
    Posts
    7,281
    It is very possible that they are looking in the wrong direction

    Meaning your cooling portion of this system "may" be functioning just fine....

    However your "Re-Heat" section of your system may not be

    The Re-Heat is there to place an artificial load on the space in order to DE-Humidify the space....

    I would place another another service call and ask to speak with the service manager to explain this.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event