Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2003
    Location
    Kansas City
    Posts
    1,482

    Confused Trane screw capacity control problem

    Trane RTUA100. Checked the chiller while I was on site doing something else and found both compressors running. A at 54% and B at 97%. B was trying to unload. Verified the clicking noise to be the male unloader solenoid pulsing. I removed the male load and unload wires off of the compressor board and manually energized the male unload solenoid. Coil is energized and compressor will not unload. Hook the gauges up to suction and the access valve below the unload valve and "manually" unloaded the compressor by dumping oil cavity pressure to suction. Compressor unloads. Next I removed my jumper and the load and unload solenoids and modulated the compressor capacity up to 90+% and then tried to unload it. Won't unload, so I "manually" unloaded the compressor again and left feeling confident that the male unload valve was bad or blocked. Ordered new valve and solenoid. Replaced valve and gasket with co2 pressurizing the compressor and verifying that air was coming out of both ports under the valve. I evac,recharged and ran compressor with male load and unload solenoids electrically disconnected. After the female unloader energized I began manually modulating this compressor and it loaded and unloaded fine until I loaded it above 85% and then it wouldn't unload unless Dumped oil from the access valve from the oil passage into the suction and then it would load and unload normally until about 85% again. So I dump oil from the access valve and unload the compressor to 64%--Female unloader energized--So I do this

    Compressor 64% both male solenoids removed--Pressures 225/66 psig-- oil cavity pressure slowly pulses up to 115psig but compressor stays stable at 64%

    pulse load solenoid with magnet--compressor loads to 84%--pressures 235/58psig--oil cavity pressure 150psig

    pulse load solenoid again--compressor loads to 93%--pressures 235/58 psig--oil cavity pressure 220psig

    pulse unloader--compressor holds at 92%--pressures do not change--cavity pressure drops and bounces between 150--160 psig.

    De-energized female unloader and compressor drops to 48%

    Repeated the above checks in various sequences and it will modulate until the compressor gets to 85+ % and then it just sticks unless the cavity pressure is dumped or the female unloader is de-energized. Can someone explain?

    If you made it this far, sorry for the long post.
    Last edited by james mo; 09-13-2011 at 05:36 PM. Reason: incorrect wording

  2. #2
    Join Date
    Feb 2006
    Location
    Atlanta,GA.
    Posts
    897
    when you say valve are you talking about the internal part ?

  3. #3
    Join Date
    Aug 2010
    Location
    Middle GA
    Posts
    104
    Strange problem. I have 2 solutions for you.
    1. did you remove the "filters" under the solenoid valve when you changed it out? sometimes they will clog up and allow pressure to pass, but not in the volume that is needed to unload the piston. I have been told by Tech support to remove them in the event of a problem such as this.
    2. You may have a sticking piston. The only way to check it is to evac the refrigerant from the compressor and use nitrogen or some other inert gas to pressurize the load / unload circuits to get the piston out to the 85% area, and try to push it back. Just to see if there is a rough spot that may be causing it to stick.

  4. #4
    Join Date
    Jan 2003
    Location
    Kansas City
    Posts
    1,482
    Quote Originally Posted by chillerout1 View Post
    when you say valve are you talking about the internal part ?
    No, the valve body that mounts to the top of the compressor


    lunchbox, thanks for the reply...I did find, remove and clean one screen, but it was the only one I saw. I guess I should slowly relieve pressure and see if it stays stuck. The piston might be able to push past a rough spot when pressure is relieved suddenly. Good input thank you.

  5. #5
    Join Date
    Aug 2010
    Location
    Middle GA
    Posts
    104
    I just thought of this, but does the compressor current (or the cavity pressure) stay steady when the load solenoid is not powered? It could be leaking by and causing the cavity to be pressurized to the point that the unload valve cannot overcome it.

  6. #6
    Join Date
    Aug 2006
    Location
    Mixing oil and fire with a big spoon.
    Posts
    4,440
    i believe that you have a failing piston/scored piston cavity.

    i recommend that you inspect the piston cavity, replace the piston and remove the pill-filters...let your customer know that a damaged piston cavity is not repairable. you could try to 'buff' it out, however, that will most likely only be a temporary fix.
    How to make the perfect "Half-Hitch" knot or any other boyscout knot in 3 easy steps...

    1. Remove your meter leads from the meter and very carefully return them to their storage case or bag.
    2. Wait 2 seconds
    3. Very carefully remove your meter leads from their storage place and enjoy your new knot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event