Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2006
    Posts
    1,027

    Hobart AM15 dishwasher help

    Got to a store, dishwasher not coming on. Dont ya know now one at the store knows what happened when it quit. Was getting 12v to the control board but not coming on.. Got a new board from Hobart and put it in.. turned on display says "Fill" but its not energizing the solenoid in the water line.

    This is only the 2nd dishwasher ive ever worked on, so im pretty much lost. Any help here would be great

  2. #2
    Join Date
    Mar 2008
    Location
    Over the river and through the woods
    Posts
    116
    did you program the board for AM select per the instructions included in the board?

  3. #3
    Join Date
    Mar 2006
    Posts
    1,027
    Quote Originally Posted by chrldwlf View Post
    did you program the board for AM select per the instructions included in the board?
    instructions

  4. #4
    Join Date
    Mar 2008
    Location
    Over the river and through the woods
    Posts
    116
    Sigh.....That board will run both the LXi and the AM select and has to be programmed correctly....I will see if I have programming instructions tomorrow

  5. #5
    Join Date
    Mar 2006
    Posts
    1,027
    no worries i got it

    on another note, what is involved in replaced the pump to tank gasket. Ive got a gasket on order for a systems thats leaking bad, just looking for a heads up

  6. #6
    Join Date
    Mar 2008
    Location
    Over the river and through the woods
    Posts
    116
    lefty loosy, righty tighty.....easy money

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event