Results 1 to 11 of 11
  1. #1
    Join Date
    Oct 2009
    Posts
    572

    Valid CryptoService?

    Im trying to send email alarms with an FX20. I found some threads on this board explaining how to set it up. As far as I know all the information is entered correctly. When I enable the SSL option I get an error "java.lang.Exception: Valid CryptoService not found." Does any one know what this means or how to fix it?

    if i disable the ssl option i get "javax.mail.MessagingException: Could not connect to SMTP host:"

    The application director is saying

    ERROR [11:05:56 11-Aug-11 EDT][email] BEmailAccount could not poll:
    javax.mail.MessagingException: Could not connect to SMTP host:
    nested exception is:
    java.net.SocketTimeoutException: Socket is not connected
    at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTra nsport.java)
    at com.sun.mail.smtp.SMTPTransport.protocolConnect(SM TPTransport.java)
    at javax.mail.Service.connect(Service.java)
    at javax.baja.email.BOutgoingAccount.pollQueue(BOutgo ingAccount.java)
    at javax.baja.email.BOutgoingAccount.poll(BOutgoingAc count.java)
    at javax.baja.email.BEmailAccount.doPoll(BEmailAccoun t.java)
    at javax.baja.email.BEmailAccount.access$0(BEmailAcco unt.java)
    at javax.baja.email.BEmailAccount$Poller.run(BEmailAc count.java)
    Caused by: java.net.SocketTimeoutException: Socket is not connected
    at java.net.PlainSocketImpl2.connectStreamWithTimeout SocketImpl2(Native Method)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:181)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:498)
    at java.net.Socket.connect(Socket.java:743)
    at com.sun.mail.util.SocketFetcher.createSocket(Socke tFetcher.java)
    at com.sun.mail.util.SocketFetcher.getSocket(SocketFe tcher.java)
    Last edited by Igotworms; 08-11-2011 at 11:08 AM.

  2. #2
    Join Date
    Apr 2007
    Location
    San Diego, CA
    Posts
    1,302
    SSL is a licensed option. Does the e-mail provider require it?
    http://www.niagara-central.com/ord?p...onThread/11374

  3. #3
    Join Date
    Oct 2009
    Posts
    572
    Thanks digo that clears that up. I decided to switch to a mail server that does not require SSL. I still can get it to work though. I followed the instructions from an AX pdf. Everything seems to be entered correctly but im still getting the following:

    Last poll failure cause: javax.mail.MessagingException: Could not connect to SMTP host
    ERROR [12:58:22 11-Aug-11 EDT][email] BEmailAccount could not poll:
    javax.mail.MessagingException: Could not connect to SMTP host: smtp-server
    nested exception is:
    java.net.SocketTimeoutException: Socket is not connected
    at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTra nsport.java)
    at com.sun.mail.smtp.SMTPTransport.protocolConnect(SM TPTransport.java)
    at javax.mail.Service.connect(Service.java)
    at javax.baja.email.BOutgoingAccount.pollQueue(BOutgo ingAccount.java)
    at javax.baja.email.BOutgoingAccount.poll(BOutgoingAc count.java)
    at javax.baja.email.BEmailAccount.doPoll(BEmailAccoun t.java)
    at javax.baja.email.BEmailAccount.access$0(BEmailAcco unt.java)
    at javax.baja.email.BEmailAccount$Poller.run(BEmailAc count.java)
    Caused by: java.net.SocketTimeoutException: Socket is not connected
    at java.net.PlainSocketImpl2.connectStreamWithTimeout SocketImpl2(Native Method)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:181)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:498)
    at java.net.Socket.connect(Socket.java:743)
    at com.sun.mail.util.SocketFetcher.createSocket(Socke tFetcher.java)
    at com.sun.mail.util.SocketFetcher.getSocket(SocketFe tcher.java)

  4. #4
    Join Date
    Jun 2004
    Posts
    709
    Do you have DNS setup? Looks like you are trying to reach smtp-server and it is unable to get to it. Could be ports blocked or you could try using an IP instead?

  5. #5
    Join Date
    Oct 2009
    Posts
    572
    I tried typing in the ip instead of the dns name but got the same result. And I believe dns is set properly in the platform since I had to use it to get the weather service to work

  6. #6
    Join Date
    Jun 2004
    Posts
    709
    Think smtp usually on port 25, do you know if they are using that or another port #?

  7. #7
    Join Date
    Oct 2009
    Posts
    572
    I think its port 25 but it didn't work. I also tried setting the port to -1 hoping that it would find another one to use but still no luck.

  8. #8
    Join Date
    Sep 2002
    Location
    Hampton Roads, Virginia
    Posts
    1,557
    Some email accounts supplied by ISP's will not allow you to connect to their smtp server unless you are connected to the internet via their system. Try setting up an email account with gmx.com, that as been the best solution for me.

    Kevin
    "Profit is not the legitimate purpose of business. The legitimate purpose of business is to provide a product or service that people need and do it so well that it's profitable."

    James Rouse

  9. #9
    Join Date
    Oct 2009
    Posts
    572
    i still get the same error with the gmx.com mail server. Is it possible that its something in the router?

  10. #10
    Join Date
    Sep 2002
    Location
    Hampton Roads, Virginia
    Posts
    1,557
    Not really likely to be router unless they are blocking or diverting any ports used for smtp, which is a possibility if they are running their own email server, in which case you may need to get an email account from the customer.

    I have attached a screenshot of my setup page.

    Kevin
    Attached Images Attached Images  
    "Profit is not the legitimate purpose of business. The legitimate purpose of business is to provide a product or service that people need and do it so well that it's profitable."

    James Rouse

  11. #11
    Join Date
    Oct 2009
    Posts
    572
    OK I got the gmx.com account to work. The port to use is 587 and not 25. Also when I was right clicking the outgoing account to test it, the fake email address that I was typing in to the "From" line was kicking me out. Thank you klrogers for the sceenshot you made my day!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event