Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2005
    Location
    Lexington, NC
    Posts
    64

    CVHE-020 capacitor grenade

    I have an CVHE that has been offline for 4 years with the power on and oil is hot. Ran the oil pump first and the start capacitor grenaded within 5 min. checked the relay and it was not stuck closed. replaced the capacitor and the new one grenaded within 5 minutes. oil pump motor must be pulling high amps due to sitting too long. quoted new pump and pump motor with relay and capacitor. am I missing something or am I on the right track?

    Thanks,

  2. #2
    Join Date
    Dec 2003
    Location
    45th Parallel
    Posts
    954
    When you pull refrig to change oil pump pull the brg insp cover also.

    Then with oil in sump and running oil pump, put a socket on rotor nut and spin shaft.
    After sitting for 4 years shaft may have take a set in front journal bearing.
    Might have to get a LARGE cheater bar to break loose.
    If you can't break loose by hand , I would try to start without the refrig in it. Cause you're looking at an overhaul if it wont break loose under power.
    “If your work speaks for itself, don't interrupt.” ~Henry J. Kaiser

  3. #3
    Join Date
    Mar 2005
    Location
    Lexington, NC
    Posts
    64
    I already started the machine once to see if it would turn and it did turn over but pressure was too high sitting in a hot room for too long. turned on the purge and told them they need a new pump and motor.

  4. #4
    Join Date
    Dec 2003
    Location
    45th Parallel
    Posts
    954
    you started the chiller motor with no oil pump?
    “If your work speaks for itself, don't interrupt.” ~Henry J. Kaiser

  5. #5
    Join Date
    Mar 2005
    Location
    Lexington, NC
    Posts
    64
    Quote Originally Posted by drivewizard View Post
    you started the chiller motor with no oil pump?
    oil pump will run for about 5 minutes until the capacitor blows up

  6. #6
    Join Date
    Dec 2008
    Location
    Dixiana, AL
    Posts
    2,609
    That's a start capacitor on the oil pump motor. If it's grenading, that means that it's staying in the circuit past start up. You sure that you don't just have a stuck start/current relay?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event