Page 2 of 2 FirstFirst 12
Results 14 to 17 of 17

Thread: Frost Forming

  1. #14
    Join Date
    Mar 2005
    Location
    Suppy NC
    Posts
    4,516
    like i said switch to emergency heat till he can get there
    if it is wired wrong or the reversing valve is stuck and it is in cooling mode or half way between you can damage the unit. should not have ice inside. if this is a mismatch may need to be wired differant then the old unit was.

  2. #15
    Join Date
    Oct 2005
    Posts
    7
    Originally posted by dkinz
    So, the air temperature outside has approached freezing, and the big pipe to your indoor unit is now frosting up?

    Call the installer to look at it and make sure everything is OK (a good idea since it has switched to heating mode and things work differently in this mode.) Your previous heat pump was probably doing the same thing, but since you had not pumped a bunch of hard earned cash into it recently, you never looked at it closely. The (big) pipe needs to be insulated all the way, otherwise it drips condensation (or melting frost) over parts of your house, causing water damage or mold or something bad.

    Get your system looked at, and get the problem fixed.
    I think you're right. The insulation goes to about an inch from the unit. That inch of non insulation is where the ice is forming. Everywhere else it seems fine. I will buy some insulation and wrap it up good. Otherwise, the unit is heating just fine. It's maintaining my apartment at 75 degrees. But outside it's only about 55 degrees or so, not close to freezing yet. I change the filter every 3 months like the packaging saids. I just changed it yesterday.

    The old unit was also a Ruud. The thermostat was changed also, I have a white Rogers thermostat.

    I will insulate and see how it goes. I will post with an answer. Thanks all again!

  3. #16
    Join Date
    Mar 2004
    Location
    Grottoes VA
    Posts
    5,856
    Turn it to EM heat you are ruining your unit. It should not have any ice inside in the winter time.

    You have a problem with your equipment.
    Karst means cave. So, I search for caves.

  4. #17
    Join Date
    Oct 2005
    Posts
    7
    Originally posted by heatpumpjesus
    o/b config doesn't ruud use "B" ?
    I guess there's a reason for your screename HeatPumpJesus. What you said was exactly the problem with my unit. When we took the cover off the outdoor unit, the pipes and compressor were filled with frost/ice. Looking over the RUUD heat pump manual the installer realized that the thermostat was set to "O" and with RUUD it should be set to "B". After making this simple change, the pipes warmed up very quickly and it now seems to be working properly. Thank you all once again for your help!


Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event