Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2000
    Location
    Flat Rock, NC
    Posts
    463

    carrier 30gt chiller exv

    I had an exv on a 1993 era chiller that the lower flange bolts stripped out of the valve body, causing a massive leak. I helicoiled them and installed new bolts. Have another valve same age on unit and it appears ok. Does the newer style exv have an improved design here or is this an isolated problem?
    Another issue is when 3rd stage energizes is unloads circuit 1 compressor, is this the correct sequence of operation? 40 ton chiller w/ 2 comps. thanks for any insight.

  2. #2
    Join Date
    Aug 2002
    Location
    Greenville SC
    Posts
    432
    The newer EXV's are a totally differant design. They are smaller and do not have any bolts. It is normal for a compressor to unload when another one starts. Stage one compressor starts unloaded. Stage two the comp. loads. Stage three the second comp. starts, and the first comp. unloads. Stage four the first comp. loads, and so on, and so on.

  3. #3
    Join Date
    Dec 2000
    Location
    Flat Rock, NC
    Posts
    463
    Thanks for the info on staging, I thought it must be correct as I checked wiring against diagram. I replaced an inaccurate evap sensor and cleared up some flooding issues as well. Kind of enjoyed working on something interesting for a change. I'm just up the hill in H'ville.

  4. #4
    Join Date
    Aug 2002
    Location
    Greenville SC
    Posts
    432
    Anytime you have a refrigeration problem with a 30gt, checkout the sensors first. Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event