Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2011
    Location
    illinois
    Posts
    3
    Post Likes

    Trane compressor problems?

    I have a trane condensing unit.That had waving head pressure,and would go off on head pressure control(400psi).I split the condenser coil which was plugged,and cleaned out with water.Ran unit again ,and had the same issue.I then recovered the refrigerant,replaced liquid line drier ,and put in new rerigerant.Now the pressures are not waving,but after 45 minutes it slowly climbs to 400psi , and goes off on head.

  2. #2
    Join Date
    Feb 2010
    Location
    In a boiler room
    Posts
    7,538
    Post Likes
    Welcome here.

    Not going to get much help here, please read the red letters above.

    If you're a tech get your post count up and apply for pro. We aren't big on DIY here.

  3. #3
    Join Date
    Jul 2011
    Location
    Canton,Ma
    Posts
    7
    Post Likes
    Did you check the xpansion valve screen? whats your low side psi doing, if it drops it sounds like unit's not metering any gas

  4. #4
    Join Date
    Oct 2009
    Location
    Cleveland
    Posts
    17
    Post Likes
    not enough info
    what is low side
    sounds like restriction

  5. #5
    Join Date
    Mar 2009
    Location
    illinois
    Posts
    1
    Post Likes
    use soap to clean coils

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Quality Home Comfort Awards