Results 1 to 8 of 8
  1. #1
    Join Date
    Apr 2004
    Posts
    131

    Liquid Level Oddness

    Got a call today about a liquid level alarm on the receiver, and when I arrived it was really low sitting at about .5%. Checked the graph on the LL and it was fluctuating between .5% and 1% since last Sunday 6/19. This seemed odd to me since usually it would bottom out at 0% with any kind of leak, and it held .5-1 for the entire week?

    This was on a supermarket rack system, and what really made me scratch the old noggin was before this it was running 39% and dropped sharply and held .5-1% for a few hours, and then jumped back up to 39%. When it bottomed out at .5-1% the second time it stayed that way for an entire week. This is my first foray into the supermarket side of things, and it seemed odd.

  2. #2
    Join Date
    Mar 2007
    Location
    Madison, Wisconsin
    Posts
    2,260
    I'm not a market tech, but sounds like a headmaster/fan cycling issue?
    I r the king of the world!...or at least I get to stand on the roof and look down on the rest of yall

  3. #3
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,567
    Just saying it is a "supermarket rack system" is kind of like saying "it's a red car"

    Tell me a bit more about the rack and about your area.

    Do you have heat reclaim? What are your ambients? What type of defrost?

  4. #4
    Join Date
    Jul 2005
    Location
    Southern California
    Posts
    585
    are there sightglasses on the receiver or did you try torching the receiver? is it really at that level or is that what the level indicator is reading?

  5. #5
    Join Date
    Dec 2010
    Location
    Central US
    Posts
    415
    like what JP said, need ambient, does it have a split condenser, roof rack, ground rack who made it, what control manufature, have you checked liquid line sight glass to see if your flashing? Might have a leak!!!!!!!!!

  6. #6
    Join Date
    Apr 2003
    Location
    Maple Grove, MN
    Posts
    1,277
    Quote Originally Posted by pherman View Post
    are there sightglasses on the receiver or did you try torching the receiver? is it really at that level or is that what the level indicator is reading?
    I dont know anything about anything, but I think pherman might be on to something.

  7. #7
    Join Date
    Jul 2005
    Location
    Southern California
    Posts
    585

    Talking

    Quote Originally Posted by ammoniadog View Post
    I dont know anything about anything, but I think pherman might be on to something.
    well thanks ammoniadog....your check is in the mail. haha

  8. #8
    Join Date
    Nov 2010
    Location
    sudbury, ontario
    Posts
    3
    I seen the same thing but without a digital scale,regardless the level on your tank is probably magnetic,probably the liquid level float has some how twisted upside down or your float is starting to fail,that being said if this was in may and assuming the temperature was not very cold out,the condenser split would have nothing to do with this, if any thing trip on on hi head...Also is this on a low temp rack,could you have several frozen up cases and hoarding the gas on the floor?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event