Mr slim stat problem? Help please.
Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2011
    Location
    e. Okla
    Posts
    14

    Mr slim stat problem? Help please.

    Mr remote thermostat is having issues.
    I get no response from the unit. The time is working on the remote and when I reset it it seems to "boot up".
    None of the other buttons seem to have any effect. I did not try the off/on button because I am afraid I wont get it to start again. Mid 90s here every day now.
    Any ideas? The remote itself or the receiving end?
    New battery s.
    Unit running fine, runs 24/7. The remote (or receiving end) may have quit many days ago. Haven't tried to adj. temp. in a month or so.

  2. #2
    Join Date
    Mar 2011
    Location
    California
    Posts
    16
    I had the same issue with a Mr.Slim a few months ago. I turned off both disconnects for the unit. Turned the one on the roof on gave it 3 mins then the other they both began to talk again and my stat started to read things correctly. Since they both communicate though the power it worked for me. Might not help you but give it a try.

  3. #3
    Join Date
    Apr 2011
    Location
    e. Okla
    Posts
    14
    I hope you are correct . I'm still not ready to turn it off right now. It takes me about 10 days to get parts, thats a long time when you don't know you ordered the right part when the temp. is in the 90s.
    I'm gonna sit tight for now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event