mcquay freezestat trip
Results 1 to 7 of 7
  1. #1
    Join Date
    Jan 2001
    Posts
    758

    mcquay freezestat trip

    I have a mcquay wshp around 4 ton I believe. The unit was tripping on freezestat. The head pressure was around 175 suction was around 45-50. I had 5 degrees. subcooling and no superheat. The supply air was 43 degrees return air was 73. I thought I had an airflow issue. blower rotation ok filter/coil clean. This has a weird ductwork run so I cut a hole is supply and return to eliminate that. The suction line freezes back to compressor and coil would eventually freeze. I took txv bulb off and tried to warm and make cold but suction didnt change. I beleive I eliminated airflow. I am thinking txv any thoughts. I did try adding some r22 but superheat is already low???(unless I dont have a full column of liquid}

  2. #2
    Join Date
    Aug 2010
    Location
    Memphis
    Posts
    343
    It probably has a txv but subcooling says it's low on refrigerant. Also what about water temp. Make sure it's warm enough

  3. #3
    Join Date
    Jun 2007
    Location
    Rochester, NY
    Posts
    29
    The first thing I would do is pull the strainer out of the water line and check for water flow and like someone already posted check the water temperature supply and return temps. of the water will tell you alot.

  4. #4
    Join Date
    Jun 2010
    Location
    Jacksonville , FL
    Posts
    11
    charge seems low , also what was the water temp coming into your heat exchanger. Pull strainer to make sure you get a good flow through the heat exchanger.

  5. #5
    Join Date
    Jan 2001
    Posts
    758
    I was wondering why superheat was so low and I had 43 degrees.maybe I didnt have a full column of liquid

  6. #6
    Join Date
    May 2010
    Location
    Minnesota
    Posts
    20
    Without a full column of liquid you would have high SH. Water flows could make a big diff in subcooling and overall operation. With that head press I would think that you've got plenty of flow but possibly too cold, or maybe too much flow. I would think that your TD across airside should be less than 30. I would think more like 20. Check your actual cfm, maybe your coil isn't as clean as it seems or something. Good luck!

  7. #7
    Join Date
    Jun 2006
    Location
    New Jersey
    Posts
    4,330
    That's wierd.....most commercial McQuay HP's I have ever worked on have a low temperature on the water heat exchanger, not on the air coil.

    Is this a geothermal or standard unit? What was the actual code on the microtech control? What were your EWT and LWT?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event