Problem with A-coil?
Results 1 to 4 of 4
  1. #1
    I recently replaced an old 10 seer leaking unit with a new weatherking. It would blow cold air sometimes and not at other times, but it never worked very well. I claimed the warranty on it and installed a new unit again. Now it is blowing air of only a 4 degree difference from the return to the vent. The pressure on the gauges on the low side now gradually increases to 120 (maxed out) and I know it had a good charge of about 70 when it was installed. The high pressure side is only getting to about 150. Anyone seen this problem? Is it time to replace the A-coil two?
    Thanks

  2. #2
    Join Date
    Jan 2003
    Location
    Kansas City
    Posts
    1,482
    You need ro re-define what a good charge really is. Look at the system, not the component. This may upset (piss you off), but claiming the warranty costs me and the homeowner money. Stop, drop and diagnose properly.

  3. #3
    Join Date
    Mar 2004
    Location
    Gone
    Posts
    5,340
    There is a Pro area you can go to in order to discuss technical situations. If you are a Pro, please fill out your credentials to prove you are and go to the Pro area, otherwise please read the site rules which state in rule 2

    RULE #2 which states:

    Do-It-Yourselfers - not here.

    This site is for industry professionals and folks seeking HVAC/R advice and knowledge. Please do not ask for step by step instructions on purchasing, installing or repairing your own HVAC equipment, that is our job and our livelihood. We are generous, but not to a fault.

    Questions of this type will not be answered and may be deleted.

  4. #4
    This is my situation. I am a maintenance man at an apartment complex, and I frequently work on A/C systems under a certified technician. I will also be certified in the near future. It is my livelihood also so please don't be offended. This problem is at my residence which I am renting from a woman. She has an A/C guy who seems stumped by the problem, and I was just trying to see if anyone had seen this type of problem. I am not certified yet but hey you've got to start somewhere. I assumed the A/C guy charged the system up correctly, but I was not there when he did it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event