Results 1 to 7 of 7

Hybrid View

  1. #1
    Join Date
    Jul 2005
    Posts
    2
    Newbie here.......great forum!

    I have a 10-11 yr-old Carrier 58PAV upflow unit that has always had trouble keeping the house cool when we have HOT weather like this, but suddenly it seems that the blower speed has dropped drastically.

    What could cause this? Bad relay?

    Thanks!!

  2. #2
    Join Date
    Aug 2002
    Location
    Office and warehouse in both Crystal River & New Port Richey ,FL
    Posts
    18,836
    Dirty filter ,components,etc.,is the most common cause,have you had it serviced and cleaned lately?

  3. #3
    Join Date
    Jul 2004
    Posts
    68
    Bad run capacitor

  4. #4
    Join Date
    Mar 2004
    Location
    Gone
    Posts
    5,340
    Call a pro. You can blow up your compressor running it in this condition.

  5. #5
    Join Date
    Dec 2002
    Location
    Tampa, Florida
    Posts
    706

    bad run cap

    bad run cap

  6. #6
    Join Date
    Jul 2005
    Posts
    2

    Thanks for replies! Would a bad capacitor.....

    .....and slower blower create a frost-up on the coils and sweating on the insulation on the vac line? That's what I'm seeing now. I shut it down last night, but there was still ice on the coils this morning.

    Thanks!!!

  7. #7
    Join Date
    Apr 2003
    Posts
    469
    Have you seen the cat recently?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event