Results 1 to 9 of 9

Thread: suction press

  1. #1
    does the suction press alternating 10 to 20 pounds every thirty seconds or so on a residential unit with the compressor running the whole time indicate air in the system,the liquid line pressure stays steady.

    if the high side fluctuates and the low side stays steady does that indicate air in the system also?


  2. #2
    Join Date
    Nov 2000
    Location
    Eastern PA
    Posts
    68,923
    Could be a hunting TXV or non-condensibles. If it is non-condensibles your discharge line from the compressor should be hotter then normal.
    Government is a disease...
    ...masquerading as its own cure…
    Ecclesiastes 10:2 NIV


  3. #3
    Join Date
    May 2005
    Location
    toronto canada
    Posts
    25
    Best way that i know of to check for non condensibles in the system is to check the head pressure with the unit off and associate it with the p/t chart then measure the temperature at the condenser and the two should match.ussually non condensables will cause high head.Does the system have a t.x.v?I have found units with this condition that have pistons as there metering device and the cause was undercharge.

  4. #4
    Join Date
    Sep 2004
    Posts
    3,157
    I can understand how a txv hunting would do that . Would a bad compressor valve plate on the suction side do the same

  5. #5
    overcharge would do it. one thing to remember also is pressures dont mean a whole lot. subooling and superheat is whats needed to diagnose any problems not pressures.

  6. #6
    Join Date
    Feb 2005
    Location
    Dothan, Al
    Posts
    3,453
    Sounds to me like maybe slightly undercharged.
    Txv trys to deliver, but not quite enough refrigerant going in, Txv opens more, finally getting enough to cool, then starts shutting down again, but alas not enough refrigerant.
    Oh well, just my two cents

    Richard

  7. #7
    Join Date
    Aug 2001
    Posts
    1,936
    an overcharged txv system will do that

  8. #8
    the hunting low pressure gauge turned out to be a shreider valve plugging up, after i reclaimed the refrigerant and vacuumed the system and recharged with new r22 the unit worked fine. ( the unit has a piston, no txv)


    I haven't been called to fix the unit with the hunting high pressure.

  9. #9
    Join Date
    Mar 2005
    Location
    Louisiana
    Posts
    211
    If it has a TXV I'd check it out first thing, sounds as though it's starving for freon being it's crawfishing I'd start looking at the TXV first off.
    If that's not the problem I'd drop the charge, change the dryer then pull a good vacume and charge it back up.
    Man, you gotta love HVAC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event