Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2005
    Posts
    33
    I had a Trane XL16i, VS air handler and Perfect-Fit electronic air cleaner installed last November. Everything has been fine until about a month ago when the EAC started popping constantly in 5-10 minute bursts that would stop once in a while and then begin again. I removed the panel for the media air filter and noticed water inside the air handler that was dripping on the EAC causing an arcing that was making the noise. My A/C repairman has been back 3 times now but I still have the same problem. They have changed the speed settings of the fan and sealed an air leak but still the problem persists.

    Any ideas would be welcome. BTW - I live in Florida and it is hot and humid this time of year...

  2. #2
    Join Date
    Aug 2002
    Location
    Office and warehouse in both Crystal River & New Port Richey ,FL
    Posts
    18,836
    Could be:

    Improper condensate drain trap,trap coming out off coil may need to go down 3" and then back up.

    High return air static pressure,can cause water to "blow" off the coil.


    We're in Florida too,Crystal River and New Port Richey.Happens a lot,duct systems aren't always what they should be,and new variable speed fans tend to bring this out,where the old unit never had enough fan power to cause a problem.

  3. #3
    Join Date
    Jun 2005
    Location
    Clearwater,FL.
    Posts
    34
    sweating is common here in the gulf coast of fl,lots of times there are good ways to minimize the problem,it does not sound like your getting the fix needed,messing with the VS settings is not a good way,only affects the efficient operation of your high end product,try talking to the service mgr. for your co. & get him or the lead tech out to try to solve or minimize the problem,though air handlers in the garage will always sweat in our humid climate,there is probably something more to your problem than sweat.if no results call your local trane dso & get the field service rep out to look at your problem or he may set you up with a second opinion with a comfort specialist dealer.hopefully you purchsed the 10yr p&l warranty on the eac & equipment.good luck

  4. #4
    Join Date
    Jun 2001
    Location
    Louisville, KY
    Posts
    12,189
    One more place to seal...electrical penetration into cabinet needs sealant. Quite often they just like to use the cheaps screw connections that are not air tight. The electrical connections are on the negative side of the blower. Hot moist air sucks in against the cold electrical control panel...bad news.

    I'm with Dash. Your problem is most likely with the design of the condensate drain trap. I'd prefer to see a 4" drop and a 2" rise.

  5. #5
    Join Date
    Jun 2005
    Posts
    33
    A/C tech was just out. Confirmed no water leaking as pre-filter is dry as a bone. His boss suggested removing the pre-filter temporarily to see if problem goes away. They have had other calls where the pre-filter is getting sucked up and making contact with the EAC grid.

    Anyone else heard of this? I am concerned as the green indicator light is now off since the pre-filter is removed and according to the manual the light should be on if the fan is running and there is power to the EAC.

    A Trane expert is going to be in town to do some supplemental training of the techs for this A/C company and they said they will ask him about this problem as well.

    I appreciate all the input as well as any additional ideas. The trap, VS settings, static pressure are up to snuff according to the tech. I will post what happens.

    Thanks!

  6. #6
    Join Date
    Aug 2002
    Location
    Office and warehouse in both Crystal River & New Port Richey ,FL
    Posts
    18,836
    Pre filter sucked into cells,sounds like high return static.

    Be sure the factoy guy checks the static.

    What does the trap look like?

  7. #7
    Join Date
    Sep 2001
    Location
    Vancouver Canada
    Posts
    996
    Don't see how a pre filter in an EAC can be sucked up against the EAC. They are made of aluminium mesh are they not? Gotta be a hell of a lot of static pressure to pull that baby out of the rack. If you had water running into the EAC I am sure it would pop and snap like crazy. Figure out why you are getting water in the filter and I am sure your problem will go away. Don't run the unit without the pre filters in for too long, they are there for good reason.
    "Go big or Go Home"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event