Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2005
    Location
    PENSYLVANIA
    Posts
    3
    I had a problem with this unit today there was a new outdoor unit installed about 2 months ago and the tenant claims that the unit is not cooling the same I put my gauges on it and notice that the back pressure was 80 psi and the head pressure was 150 psi and putting a charge in it was like pulling teeth, the suction line is sweating good. supply is 61f, suction line was about 63f. What is going on with this unit. Its NOT a leak service valves are new and not a restriction any where by the look of my pressures. Thank you for any comments

  2. #2
    Join Date
    May 2003
    Location
    Sarasota. Fl
    Posts
    1,286
    Indoor and outdoor temps?

    Subcooling?

    Delta across coil?

    Need more info.
    It is the job of thinking people not to be on the side of the executioners.

    ~Albert Camus

  3. #3
    Join Date
    Nov 2000
    Location
    Eastern PA
    Posts
    68,962
    Sounds like an oversized metering device.
    Government is a disease...
    ...masquerading as its own cure…
    Ecclesiastes 10:2 NIV


  4. #4
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    68,337
    Did some one install a smaller outdoor unit then what was originally there?
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  5. #5
    Join Date
    Nov 2003
    Location
    South Carolina
    Posts
    1,167
    Wrong size or missing piston.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event