Page 1 of 5 12345 LastLast
Results 1 to 13 of 60

Hybrid View

  1. #1
    Join Date
    Mar 2005
    Posts
    65
    Called to a "low-on-freon-call" today.Everything running except compressor.Shell cool to touch,but discharge burnt the heck out of me.External thermal limit safety switch stuck open.Gages showed 150 psig high-low.Ohmed out compressor,no shorts to each other or to ground or broken windings.Jumpered pass defective switch per bosses orders and turned her on.Compressor fired up good,head got to about 200 and "BOOM".Terminal block at compressor blew up like a grenade spewing sparks,refrigerent and oil.After charging cust. 65 dollars I started wondering why it blew.What do you guys conclude.I'm guessing internal corrosion caused by acid in system due to running hot too long with contaminates?I'm still new to this stuff,not out of school yet.Any thoughts appreciated.

  2. #2
    Join Date
    Feb 2004
    Posts
    2,597
    i conclude that you will never jumper that switch again.

  3. #3
    Join Date
    Mar 2005
    Location
    Suppy NC
    Posts
    4,513
    unit tripped the saftey for a reason
    should not jump it out find the reason

  4. #4
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    68,603
    You jumped out a saftey that was doing its job.

    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  5. #5
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    68,603
    You jumped out a saftey that was doing its job.

    If the discharge line is that hot, wait till it cools.

    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  6. #6
    Join Date
    Oct 2003
    Location
    Florida's space coast
    Posts
    2,538
    I'll bet that scared the hell out of you.

    Could be that the motor insulation was damaged but if your like a lot of techs your meter probably only reads to 10 or 20 meg ohms.

    A leak of say 40 meg ohms may not be detected but let it run a few minutes and the winding heats up it will find ground.

    Keep in mind not being there this is only a guess and just some food for thought.
    We've been doing so much,for so long,with so little, that now we can do almost anything, with nothing at all.

  7. #7
    Join Date
    May 2004
    Posts
    12,230
    that still doesn't answer his question.

    we have all jumped out the clickson.

    why when the can is cool the discharge is burning hot

    why when he fires it up it blows? ?

    Hi side plugged at discharge?

  8. #8
    Join Date
    Nov 2000
    Location
    Eastern PA
    Posts
    68,964
    More then likely the compressor went into a vacuum arching internally causing the oil to combust.
    Government is a disease...
    ...masquerading as its own cure…
    Ecclesiastes 10:2 NIV


  9. #9
    Join Date
    Nov 2003
    Posts
    501
    You can look on the bright side of this situation...if you do the replacement, there won't be any recovery necessary.

  10. #10
    Join Date
    Dec 2002
    Location
    Houston,Tx.
    Posts
    16,115
    Originally posted by dorrmann
    You can look on the bright side of this situation...if you do the replacement, there won't be any recovery necessary.
    Speaking of recovery you could be in there tonight thanks to your boss.
    __________________________________________________ _______________________
    “Experience is a hard teacher because she gives the test first, the lesson afterwards". - Vernon Law

    "Never let success go to your head, and never let failure go to your heart". - Unknown

  11. #11
    Join Date
    Nov 2000
    Location
    Eastern PA
    Posts
    68,964
    So, was the oil black and stinky?
    Government is a disease...
    ...masquerading as its own cure…
    Ecclesiastes 10:2 NIV


  12. #12
    Join Date
    Oct 2004
    Posts
    3,400
    That's why there's a cover on the terminals.

    You DID put it back on before running it, didn't you?

    What kind of meter did you ohm it with?
    What setting?

  13. #13
    Join Date
    Dec 2003
    Location
    Kenilworth New Jersey
    Posts
    230

    Wink

    Did they pay the $65 ?

Page 1 of 5 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event