geothermal trouble
Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2004
    Posts
    9
    Have a year old Water Furnace. It will not heat using the heat pump side of it. Only the emergency heat works on it. The "water flow" lite is blinking, and it is the only lite on the control board which is blinking. The water pumps which control the flow of the water thru the outdoor pipes, are not working. any help would be appreciated.

  2. #2
    Join Date
    Mar 2004
    Location
    Grottoes VA
    Posts
    5,856
    Waterfurnace is not a DIY piece of equipment. You can check the breakers (turn them off and then back on) if this doesn't solve the problem please call the installer back. The board could be bad, the fuse blown or loose wires, just to name a few things that could be wrong.
    Karst means cave. So, I search for caves.

  3. #3
    Join Date
    Jul 2004
    Posts
    68
    The water flow lite is blinking because the freeze protection thermistor senses no flow from the pumps. the unit locks out after two trials to start. The control board energizes the pumps thru a relay. Check the wiring diagram. There are fuses on the board for the 240 volt circuit.The compressor section has it's own power supply seperate from the blower and 24v circuit. Do you have a M/N?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event