Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2004
    Posts
    4
    Post Likes
    People I need an answer ASAP I ran our of oil tonight so I went to the gas station, got some Kero and used that, upon resetting the system it still was blowing out cold air. HELP this is a 10 year old Beckett Oil Burner in a Uni-Cell system.
    I am freezing and so is my mom. I know a few things about HVAC so tell me what I need to know!!! Thanks


  2. #2
    Join Date
    Feb 2005
    Posts
    1,475
    Post Likes
    If the tank really ran out you may have clogged up the oil filter you need to check for oil pressure. I do not know much about oil I won't be able to help you with much more than that.

  3. #3
    Join Date
    Oct 2004
    Posts
    4
    Post Likes
    Any possibility that the 5 gal I put in is not enough to start the burner?

  4. #4
    Join Date
    Jul 2002
    Location
    Zelienople, Pa
    Posts
    2,965
    Post Likes
    Very possible.
    It is also very possible you clogged the filter and nozzle up by running it dry.
    You need to call a 24hr technician to fire it up safely again.
    P.S. also let him know how many times you hit the reset button. You could save his life!
    How tall are you Private???!!!!

  5. #5
    Join Date
    Oct 2004
    Posts
    4
    Post Likes
    I got it, I forgot to bleed the line... And I know not to press the reset button more than once, I may be 16 1/2... But I still know a thing or two about HVAC, Thanks you guys..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Comfortech365 Virtual Event