Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2005
    Post Likes


    I have just tried to replace my Honeywell thermostat with a digital touch screen ritemp 8030C. It seemed to be a trivial installation: Y to Y, R to RH (which is jumpered to RC on the ritetemp), W to W, and G to G. The heat worked fine but the AC didn't cut on (although the blower did). I reinstalled my original Honeywell and have the same problem: heat but no AC. Did I screw up my AC or is it just a coincidence that am I having a problem with my AC now?

  2. #2
    Join Date
    May 2000
    Indianapolis, IN, USA
    Post Likes
    Probably coincidence, doesn't look like anything was wired wrong. Did you check the breaker to the outdoor unit?

  3. #3
    Join Date
    Jul 2003
    Post Likes
    Good ol baldLoonie, always willing to help...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.