Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2005
    Posts
    1
    Hello

    I've got a Majestic HE25RN natural gas insert which recently started having a problem. The pilot light stays lit but when I turn on the switch to produce flame nothing happens. The switch contact is OK.

    Any idea/suggestions on what is causing this problem??

  2. #2
    Join Date
    Dec 2003
    Location
    south NJ shore area
    Posts
    360

    fireplace

    try to turn the gas valve to the on posistion.
    GOOD WORK IS NOT CHEAP! AND CHEAP WORK IS NOT GOOD!

    IF YOU THINK A GOOD HVAC COMPANY IS EXPENSIVE. THEN YOU SHOULD TRY A BAD ONE.

  3. #3
    Join Date
    Feb 2005
    Posts
    102
    what kind of switch is it ,jump the switch.

  4. #4
    Join Date
    Jan 2005
    Posts
    99
    Rauchen, the millivolt reading at the gas valve needs to be at minimum 300 m.v. to actuate gas valve. Im assumming this is a millivolt system? If you find a lower reading than 300 m.v. check pilot and or pilot generator and clean or replace as neccessary.

  5. #5
    Join Date
    Jun 2003
    Location
    New Hampshire
    Posts
    2,666
    When this happens the pilot is usually strong enough to keep the pilot energized but if the pilot is a little dirty the millivoltage is not enough to energize the main valve. There is a voltage drop in the wire to the switch and back again.
    We are talking millivolts here.


    You can post this on the "fireplaces section" too for more replies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event