Results 1 to 4 of 4
  1. #1
    heatseeker Guest

    Question

    I have been working on a york furnace that is acting crazy ,the board says it is locking out because of a roll out switch. all rollout and pressure switches check out good (24 volts etc). The unit has manual reset switches on it and all of them right. This thing will run right, heat up and shut off then , house cools down and it will call for heat but no ignition, ignitor glows sometimes,sometimes it doesn't, sometimes it glows twice but the gas valve won't open. turn it off for awhile then turn it back on and it will warm up the house and act up again. board always flashes roll out switch open.

    [Edited by heatseeker on 02-01-2005 at 08:20 PM]

  2. #2
    Join Date
    Feb 2004
    Posts
    2,597
    you're losing voltage somewhere. trace it.

  3. #3
    Join Date
    Apr 2003
    Location
    Iowa
    Posts
    763
    look for bad connections, board could be bad..... rollout switches are ok? limit is not opening?

  4. #4
    Join Date
    Jan 2005
    Location
    Gilroy, Calif
    Posts
    188
    put jumpers on roll out sw and run a cycle. I know this may sound stupid but the flame shield is in place, right?

    [Edited by gje1 on 02-03-2005 at 10:14 PM]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event