Results 1 to 2 of 2

Thread: reverse osmosis

  1. Question

    I have run into a problem with the Honeywell steam humidifiers. I have had this same problem twice now and Honeywell seems to have no answers. I am having a problem with the reverse osmosis filter not allowing the water flow to the humidifier. There is plenty of water pressure to the filter and all water goes to the overflow (which seems to be a terrible design to me). I have even capped the overflow off to try and get the water ther but had no positive results. Honeywell answer was give it 45 minutes to fill as they could not understand there is no water flowing to the humidifier. Any positive feedback will be greatly appreciated.

  2. #2
    Join Date
    Aug 2003
    Location
    Ft Worth Tx ( North Richland Hills)
    Posts
    2,143
    Give some more information.

    Do you have pre-filters? (sand filter)(5 micron cartridge filter)

    Is there a pump on your system?

    If you're blocking the overflow ...the system will not work.
    The nature of the system requires that for every gallon of RO water you get, 4 to 10 gallons of "flush water " have to go down the drain.

    The membranes in the RO cylinder have a max lifetime of 4 years.. depending on how hard your water starts out...also changing the pre-filters regularly is a must.

    If you have pre-filters (especially the sand/carbon filters) if the system isn't flushed properly you can get carbon particles plugging the makeup water valve at the humidifier.

    [Edited by ozone drone on 12-20-2004 at 06:48 AM]
    How can you have any pudding if you don't eat your meat?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event