Results 1 to 7 of 7
  1. #1

    Carrier 58PAV070-12 with error code 31, please help!

    I have a 10 years old Carrier 58PAV070-12 furnace with a problem. The blower comes on, but it never ignites. It is giving me error code 12 first, then 31. My understanding of that code 31 has to do with the venting of the furnace or pressure switch. I did some troubleshooting myself already. I tried cleaning up the pressure switch, the rubber tube going to it. I also tried taking the two wires off pressure switch and jumper them together when the inducer motor is running, still no ignition. There doesn't seem to be any air blockage on the unit. What am I missing here? Anything else I should have checked? The pressure switch seems to be working fine, motor inducer is running, no blockage, filter is clean, any suggestions? Could it be something to do with the ignition heating element? Please help, Thanks much!

  2. #2
    I read some posts talking the air switch could be bad, so what I did was to bypass the air switch, but still the hot surface igniter is not glowing, not even hot. that's how I determined the air switch shouldn't be the cause.

  3. #3
    I'm getting the same error code 31 when I bypassed the switch. Initially the error code is 12 for 90 seconds, then induce motor is on, error code became 31, I used a safety pin bypassed the pressure switch. I also used multimeter to measure the resistance of hot surface ignitor, it was about 66 ohm which i think it's a good reading. I'm not sure what else to check now, could the problem be related to the board?

  4. #4
    Join Date
    Jun 2006
    Location
    Richmond, VA
    Posts
    2,922
    If the flashing light is out-check the breaker
    If there are error codes-Call A tech

  5. #5
    Join Date
    Apr 2006
    Location
    Ontario
    Posts
    13
    Quote Originally Posted by peterzhang View Post
    I'm getting the same error code 31 when I bypassed the switch. Initially the error code is 12 for 90 seconds, then induce motor is on, error code became 31, I used a safety pin bypassed the pressure switch. I also used multimeter to measure the resistance of hot surface ignitor, it was about 66 ohm which i think it's a good reading. I'm not sure what else to check now, could the problem be related to the board?
    You can't bypass the air switch before inducer motor starts. or it will fault on a code 31.

    You have to let the inducer motor run first, then jump out the switch, then it should go to the ignitor. Don't use a paper clip, you might get juiced...

    Aren't you getting cold yet>>


  6. #6
    Join Date
    Apr 2006
    Location
    Ontario
    Posts
    13
    I still think it's the air switch. Is it an all metal tin can switch??

  7. #7
    Join Date
    Apr 2006
    Location
    Ontario
    Posts
    13
    Quote Originally Posted by peterzhang View Post
    I used a safety pin bypassed the pressure switch.?
    Safety pins are for diapers not bypassing switches.

    Try a piece of sheilded wire.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event