Recommendation for Carbon furnace filter for odor issue?
Results 1 to 4 of 4
  1. #1
    Join Date
    May 2003
    Location
    Northeast Ohio
    Posts
    130
    I have a Carrier 58 MVP furnace (100,000 BTU) and a 2-speed Carrier AC with cased A-coil. I also have the 20" EZ Flex filter underneath it, above the under-slab returns. I've been getting an odd/faint burning/slightly musty odor with furnace operation with this new system. The new system was installed in June 2004 and they've replaced the blower motor that locked up, inducer fan motor that died, pressure switches, and main board, and I'm on my third thermostat due to the dehumidify function not working. The furnace has been a lemon. The blower and its compartment and coil and its case show no signs of anything besides a little dust from my EZ Flex filter blow-by issue.

    In summer of '03, the foundation was dug completely, foundation waterproofed, and drain tile was installed. I left the old HVAC system in place for nine months after that without replacing system to make sure ducts did not re-flood or give off odor before purchasing a new system. They did not and I had no trace of any odor or water, even after heavy rains. I actually had no odor at all until the original inducer fan casing in the MVP furnace allowed water into my new furnace during rains back in late July '04, due to 2" of sealer missing from the factory on the inducer fan casing. It was water that came down the PVC pipe from the roof when it rained. After repair and filter replacement, that damp odor was gone. It wasn't until the furnace was later used in late September that this new odor popped up. I think this odor is a furnace problem. Check out my thread under residential for all my furnace troubles. Dealer claims it's my ductwork under the slab, yet there is not a trace of water and I had no odor with the previous system and none with the new AC(only furnace) except for the previously mentioned inducer casing issue.

    I'm not impressed with my EZ-Flex filter. They used the assembled-on-site cabinet that came with the furnace and the filter fit is not tight and I'm getting blow-by. I want to try a 1" carbon filter in the blower compartment above to test the dealer's theory.

    -Could any of you recommend a specific carbon filter and point out any negatives to using them, if there are any?

    -Can the carbon filter be used in conjunction with the EZ Flex or will there be too much pressure drop?

    -What can I do with the cabinet of the EZ Flex to fix the blow-by issue? Foam tape on the sides, etc.?

  2. #2
    Join Date
    Nov 2004
    Posts
    17
    I would recomend to call a contractor who specializes in IAQ (Indoor Air Quality) to give you a good assesment about all those issues that you are talking about. Also I don't think the manufacturer would forget to install the seals in the inducer housing, but I may be wrong. You definitively need a second opinion about the installation of your equipment, there are so many things that you are describing and they could be due to poor installation. An IAQ contractor will recommend the best filtration system for your particular problem.

    good luck.

  3. #3
    Join Date
    May 2003
    Location
    Northeast Ohio
    Posts
    130
    Thanks for the reply. I do have someone like you mentioned coming out, hopefully next week.

    The inducer fan housing seal was in fact missing two inches of seal right from the factory. When the tech removed the housing after seeing the water leaking from it, he removed the screws/bolts to split it open, and sure enough, the sealer was missing a full 2" at the bottom left side, allowing the rain water from the exhaust pipe to leak out into the furnace instead of going down the drain hole and into the trap inside the furnace. It's a good thing it wasn't heating season at the time, or the amount of water from the secondary heat exchanger would have been much worse.

    I'm very pleased with the install itself. It looks top notch and the installer for this dealer has 15 years experience in Carrier installations. The problem has been internal furnace parts failures and this odor. This dealer has a great reputation around here. I believe the problems resulted from the water leakage. The failed blower motor had water spots all over the cap and the control board also had a water spot, both resulting from the water leak out of the inducer fan right above them.

    I want to give this carbon filter a try before anyone comes out. If the smell disappears, it will prove the dealer correct in their blame of my underground returns. If the smell stays, it will prove me correct. My only mechanical issue with the furnace now is the repeated Code 32 faults-Low Pressure Switch open. I've read that high wind can trip that and it has indeed tripped in excessive wind, but also with no wind.

  4. #4
    Join Date
    May 2003
    Location
    Northeast Ohio
    Posts
    130
    Thanks for the reply. I have asthma and electronic air cleaners give off ozone. Unfortunately, that won't work for me but thanks for the idea and the offer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event